aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 8577c8a15c..b8d63b8479 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1133,6 +1133,38 @@ also ensuring that the notebooks are running without errors.")
"This package provides a pytest plugin for testing console scripts.")
(license license:expat)))
+(define-public python-pytest-tornasync
+ (package
+ (name "python-pytest-tornasync")
+ (version "0.6.0.post2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-tornasync" version))
+ (sha256
+ (base32
+ "0pdyddbzppkfqwa7g17sdfl4w2v1hgsky78l8f4c1rx2a7cvd0fp"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #false ; TODO: fails at "from test import MESSAGE, PAUSE_TIME"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "--verbose")))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-tornado" ,python-tornado)))
+ (home-page "https://github.com/eukaryote/pytest-tornasync")
+ (synopsis "Pytest plugin for testing Tornado code")
+ (description
+ "This package provides a simple pytest plugin that provides some helpful
+fixtures for testing Tornado (version 5.0 or newer) apps and easy handling of
+plain (undecoratored) native coroutine tests.")
+ (license license:expat)))
+
(define-public python-pytest-env
(package
(name "python-pytest-env")
-01-29doc: Replace a stale reference to a code snippet....Tobias Geerinckx-Rice 2018-01-28doc: Mention escpr in CUPS configuration example....Diego Nicola Barbato 2018-01-21doc: Improve ‘fix-runpath’ description....Tobias Geerinckx-Rice 2018-01-21services: Missing services are automatically instantiated....Ludovic Courtès 2018-01-19gnu: Consistently Write ‘file system(s)’....Tobias Geerinckx-Rice 2018-01-17docs: Fix typo in qemu-binfmt example....Danny Milosavljevic 2018-01-17gnu: services: web: Add service for httpd....Christopher Baines 2018-01-16doc: Fix typo....Ludovic Courtès 2018-01-15doc: Deprecate 'bitlbee-service' procedure....Ludovic Courtès 2018-01-15services: bitlbee: Move to (gnu services messaging)....Ludovic Courtès 2018-01-15doc: Connect "guix archive", "guix pack", and co....Ludovic Courtès 2018-01-14doc: Correct documentation of NGINX-LOCATION-CONFIGURATION....Andreas Enge 2018-01-11services: qemu-binfmt: Extend guix-daemon with extra chroot directories....Ludovic Courtès 2018-01-11services: Add qemu-binfmt....Ludovic Courtès 2018-01-11doc: Fix typo in 'guix environment' example....Ludovic Courtès 2018-01-08gnu: services: Add darkstat service....宋文武 2018-01-08services: guix: Add 'log-compression' option....Ludovic Courtès 2018-01-07publish: Publish build logs....Ludovic Courtès 2018-01-07doc: Mark zlib as mandatory, libbz2 as optional....Ludovic Courtès 2018-01-07daemon: Add gzip log compression....Ludovic Courtès 2018-01-06doc: Describe Wayland status....Rutger Helling 2017-12-30doc: Fix typo....Mark H Weaver 2017-12-30gnu: services: Add MATE desktop service....ng0 2017-12-29services: networking: Add a dependency override mechanism to <static-networki......Marius Bakke 2017-12-26doc: Fix typo....Tobias Geerinckx-Rice 2017-12-24gnu, doc: Use HTTPS for cran.r-project.org home pages....Tobias Geerinckx-Rice 2017-12-24services: messaging: Use HTTPS for prosody.im URLs....Tobias Geerinckx-Rice 2017-12-23doc: Properly escape brackets....Tobias Geerinckx-Rice 2017-12-23gnu: dovecot: Update to 2.3.0....Tobias Geerinckx-Rice