aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 08ae11724c..294b99230f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -104,14 +104,14 @@
;; Yeah, Perl... It is required early in the bootstrap process by Linux.
(package
(name "perl")
- (version "5.34.0")
+ (version "5.36.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/src/5.0/perl-"
version ".tar.gz"))
(sha256
(base32
- "16mywn5afpv1mczv9dlc1w84rbgjgrr0pyr4c0hhb2wnif0zq7jm"))
+ "02p0ljvxgay5g8s8j1kghdylkj581qx3qlwavlmgd5n3iapqaq72"))
(patches (search-patches
"perl-no-sys-dirs.patch"
"perl-autosplit-default-time.patch"
@@ -239,10 +239,9 @@
"/lib',\n"))))
config2)))))))
(inputs
- (append (list coreutils-minimal)
- (if (%current-target-system)
- (list bash-minimal)
- '())))
+ (if (%current-target-system)
+ (list bash-minimal coreutils-minimal)
+ '()))
(native-inputs
(if (%current-target-system)
`(("perl-cross"
@@ -250,10 +249,10 @@
(method git-fetch)
(uri (git-reference
(url "https://github.com/arsv/perl-cross")
- (commit "1.3.6")))
- (file-name (git-file-name "perl-cross" "1.3.6"))
+ (commit "1.4")))
+ (file-name (git-file-name "perl-cross" "1.4"))
(sha256
- (base32 "0k5vyj40czbkfl7r3dcwxpc7dvdlp2xliaav358bviq3dq9vq9bb")))))
+ (base32 "1ydjvlhrk06ccyj4bm8by7xk90krsll2k380mc3x1mhfrc7r9gzy")))))
'()))
(native-search-paths (list (search-path-specification
(variable "PERL5LIB")