Taken from upstream.
From b0cd77e588620465b78f7c017d3f240e13936aa3 Mon Sep 17 00:00:00 2001
From: Pavlo Solntsev
Date: Sun, 19 Sep 2021 22:51:38 -0500
Subject: [PATCH] Test: Skip test if no server available
Two variables will be checked. If they set
and provide all needed information the test
will be executed. If they are not set, the test
will return TRUE and will terminate with
termination status EXIT_SUCCESS.
---
tests/db/check-db-catalog-postgresql.c | 16 ++++++++++++++++
tests/test-server-operation-postgresql.c | 16 ++++++++++++++++
2 files changed, 32 insertions(+)
diff --git a/tests/db/check-db-catalog-postgresql.c b/tests/db/check-db-catalog-postgresql.c
index 5b8e9395c..bf9a8942c 100644
--- a/tests/db/check-db-catalog-postgresql.c
+++ b/tests/db/check-db-catalog-postgresql.c
@@ -25,6 +25,9 @@
#include
#include "../test-cnc-utils.h"
+#define PROVIDER_DB_CREATE_PARAMS "POSTGRESQL_DBCREATE_PARAMS"
+#define PROVIDER_CNC_PARAMS "POSTGRESQL_CNC_PARAMS"
+
typedef struct {
GdaDbCatalog *catalog;
GdaConnection *cnc;
@@ -