aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/u-boot-video-rockchip-fix-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/u-boot-video-rockchip-fix-build.patch')
-rw-r--r--gnu/packages/patches/u-boot-video-rockchip-fix-build.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/gnu/packages/patches/u-boot-video-rockchip-fix-build.patch b/gnu/packages/patches/u-boot-video-rockchip-fix-build.patch
deleted file mode 100644
index ca2be8dc22..0000000000
--- a/gnu/packages/patches/u-boot-video-rockchip-fix-build.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From ecc69ec25df07e1ce63d7add6b235b37673ed608 Mon Sep 17 00:00:00 2001
-From: Peter Robinson <pbrobinson@gmail.com>
-Date: Mon, 20 Apr 2020 19:18:25 +0100
-Origin: https://patchwork.ozlabs.org/project/uboot/patch/20200420181825.935797-1-pbrobinson@gmail.com/
-Subject: [PATCH 6/6] drivers: video: rockchip: fix building eDP and LVDS
- drivers
-
-The rk_edp.c and rk_lvds.c files reference rk_setreg which is declared in
-hardware.h so include it so the drivers build. Adjust rk_lvds.c so
-includes are in alphabetical order while updating.
-
-Signed-off-by: Peter Robinson <pbrobinson@gmail.com>
-Reviewed-by: Anatolij Gustschin <agust@denx.de>
----
- drivers/video/rockchip/rk_edp.c | 1 +
- drivers/video/rockchip/rk_lvds.c | 3 ++-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/drivers/video/rockchip/rk_edp.c b/drivers/video/rockchip/rk_edp.c
-index 8703df0ec0..cf84b886e7 100644
---- a/drivers/video/rockchip/rk_edp.c
-+++ b/drivers/video/rockchip/rk_edp.c
-@@ -18,6 +18,7 @@
- #include <asm/arch-rockchip/clock.h>
- #include <asm/arch-rockchip/edp_rk3288.h>
- #include <asm/arch-rockchip/grf_rk3288.h>
-+#include <asm/arch-rockchip/hardware.h>
- #include <dt-bindings/clock/rk3288-cru.h>
-
- #define MAX_CR_LOOP 5
-diff --git a/drivers/video/rockchip/rk_lvds.c b/drivers/video/rockchip/rk_lvds.c
-index cf5c0439b1..79e24baf53 100644
---- a/drivers/video/rockchip/rk_lvds.c
-+++ b/drivers/video/rockchip/rk_lvds.c
-@@ -13,8 +13,9 @@
- #include <asm/gpio.h>
- #include <asm/io.h>
- #include <asm/arch-rockchip/clock.h>
--#include <asm/arch-rockchip/lvds_rk3288.h>
- #include <asm/arch-rockchip/grf_rk3288.h>
-+#include <asm/arch-rockchip/hardware.h>
-+#include <asm/arch-rockchip/lvds_rk3288.h>
- #include <dt-bindings/clock/rk3288-cru.h>
- #include <dt-bindings/video/rk3288.h>
-
---
-2.20.1
-
rvice-type (name 'marionette-repl) (extensions (list (service-extension shepherd-root-service-type marionette-shepherd-service))) (description "The @dfn{marionette} service allows a guest system (virtual machine) to be manipulated by the host. It is used for system tests."))) (define* (marionette-operating-system os #:key (imported-modules '()) (extensions '()) (requirements '())) "Return a marionetteed variant of OS such that OS can be used as a marionette in a virtual machine--i.e., controlled from the host system. The marionette service in the guest is started after the Shepherd services listed in REQUIREMENTS. The packages in the list EXTENSIONS are made available from the backdoor REPL." (operating-system (inherit os) ;; Make sure the guest dies on error. (kernel-arguments (cons "panic=1" (operating-system-user-kernel-arguments os))) ;; Make sure the guest doesn't hang in the REPL on error. (initrd (lambda (fs . rest) (apply (operating-system-initrd os) fs #:on-error 'backtrace rest))) (services (cons (service marionette-service-type (marionette-configuration (requirements requirements) (extensions extensions) (imported-modules imported-modules))) (operating-system-user-services os))))) (define-syntax define-os-with-source (syntax-rules (use-modules operating-system) "Define two variables: OS containing the given operating system, and SOURCE containing the source to define OS as an sexp. This is convenient when we need both the <operating-system> object so we can instantiate it, and the source to create it so we can store in in a file in the system under test." ((_ (os source) (use-modules modules ...) (operating-system fields ...)) (begin (define os (operating-system fields ...)) (define source '(begin (use-modules modules ...) (operating-system fields ...))))))) ;;; ;;; Simple operating systems. ;;; (define %simple-os (operating-system (host-name "komputilo") (timezone "Europe/Berlin") (locale "en_US.UTF-8") (bootloader (bootloader-configuration (bootloader grub-bootloader) (targets '("/dev/sdX")))) (file-systems (cons (file-system (device (file-system-label "my-root")) (mount-point "/") (type "ext4")) %base-file-systems)) (firmware '()) (users (cons (user-account (name "alice") (comment "Bob's sister") (group "users") (supplementary-groups '("wheel" "audio" "video"))) %base-user-accounts)))) (define-syntax-rule (simple-operating-system user-services ...) "Return an operating system that includes USER-SERVICES in addition to %BASE-SERVICES." (operating-system (inherit %simple-os) (services (cons* user-services ... %base-services)))) ;;; ;;; Tests. ;;; (define-record-type* <system-test> system-test make-system-test system-test? (name system-test-name) ;string (value system-test-value) ;%STORE-MONAD value (description system-test-description) ;string (location system-test-location (innate) ;<location> (default (and=> (current-source-location) source-properties->location)))) (define (write-system-test test port) (match test (($ <system-test> name _ _ ($ <location> file line)) (format port "#<system-test ~a ~a:~a ~a>" name file line (number->string (object-address test) 16))) (($ <system-test> name) (format port "#<system-test ~a ~a>" name (number->string (object-address test) 16))))) (set-record-type-printer! <system-test> write-system-test) (define-gexp-compiler (compile-system-test (test <system-test>) system target) "Compile TEST to a derivation." (mparameterize %store-monad ((%current-system system) (%current-target-system target)) (system-test-value test))) (define (test-modules) "Return the list of modules that define system tests." (scheme-modules (dirname (search-path %load-path "guix.scm")) "gnu/tests" #:warn warn-about-load-error)) (define (fold-system-tests proc seed) "Invoke PROC on each system test, passing it the test and the previous result." (fold-module-public-variables (lambda (obj result) (if (system-test? obj) (cons obj result) result)) '() (test-modules))) (define (all-system-tests) "Return the list of system tests." (reverse (fold-system-tests cons '()))) ;; Local Variables: ;; eval: (put 'with-imported-modules-and-extensions 'scheme-indent-function 2) ;; End: ;;; tests.scm ends here