aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch')
-rw-r--r--gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch b/gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch
new file mode 100644
index 0000000000..7f100d04bd
--- /dev/null
+++ b/gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch
@@ -0,0 +1,25 @@
+diff --git a/Cargo.toml b/Cargo.toml
+index 57924f1..0c59727 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -43,11 +43,6 @@ bench = false
+ version = "0.4"
+ optional = true
+
+-[dependencies.blas-src]
+-version = "0.6.1"
+-optional = true
+-default-features = false
+-
+ [dependencies.cblas-sys]
+ version = "0.1.4"
+ optional = true
+@@ -92,7 +87,7 @@ version = "0.9"
+ default-features = false
+
+ [features]
+-blas = ["cblas-sys", "blas-src"]
++blas = ["cblas-sys"]
+ docs = ["approx", "serde", "rayon"]
+ serde-1 = ["serde"]
+ test = ["test-blas-openblas-sys"]