aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ruby-nokogiri.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ruby-nokogiri.patch')
-rw-r--r--gnu/packages/patches/ruby-nokogiri.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/ruby-nokogiri.patch b/gnu/packages/patches/ruby-nokogiri.patch
new file mode 100644
index 0000000000..b55b430234
--- /dev/null
+++ b/gnu/packages/patches/ruby-nokogiri.patch
@@ -0,0 +1,29 @@
+Description: Removed some unnecessary test setup such as SimpleCov and
+ minitest-reporters.
+diff --git a/test/helper.rb b/test/helper.rb
+index ed3133c6..4f5d4f1b 100644
+--- a/test/helper.rb
++++ b/test/helper.rb
+@@ -13,22 +13,10 @@
+ # - NOKOGIRI_GC: read more in test/test_memory_leak.rb
+ #
+
+-require "simplecov"
+-SimpleCov.start do
+- add_filter "/test/"
+- enable_coverage :branch
+-end
+-
+ $VERBOSE = true
+
+ require "minitest/autorun"
+ require "minitest/benchmark"
+-require "minitest/reporters"
+-
+-nokogiri_minitest_reporters_options = { color: true, slow_count: 10, detailed_skip: false }
+-nokogiri_minitest_reporters_options[:fast_fail] = true if ENV["NOKOGIRI_TEST_FAIL_FAST"]
+-puts "Minitest::Reporters options: #{nokogiri_minitest_reporters_options}"
+-Minitest::Reporters.use!(Minitest::Reporters::DefaultReporter.new(nokogiri_minitest_reporters_options))
+
+ require "fileutils"
+ require "tempfile"