aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/qtdeclarative-disable-qmlcache.patch')
-rw-r--r--gnu/packages/patches/qtdeclarative-disable-qmlcache.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch b/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch
new file mode 100644
index 0000000000..5f06ec53b4
--- /dev/null
+++ b/gnu/packages/patches/qtdeclarative-disable-qmlcache.patch
@@ -0,0 +1,16 @@
+Retrieved from
+https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/libraries/qt-6/patches/qtdeclarative-default-disable-qmlcache.patch
+
+diff --git a/src/qml/jsruntime/qv4engine.cpp b/src/qml/jsruntime/qv4engine.cpp
+index 852cde9e..165f1b57 100644
+--- a/src/qml/jsruntime/qv4engine.cpp
++++ b/src/qml/jsruntime/qv4engine.cpp
+@@ -2093,7 +2093,7 @@ void ExecutionEngine::registerModule(const QString &_name, const QJSValue &modul
+
+ bool ExecutionEngine::diskCacheEnabled() const
+ {
+- return (!disableDiskCache() && !debugger()) || forceDiskCache();
++ return forceDiskCache();
+ }
+
+ void ExecutionEngine::callInContext(QV4::Function *function, QObject *self,