aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch')
-rw-r--r--gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch b/gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch
new file mode 100644
index 0000000000..2f1cf0dd4e
--- /dev/null
+++ b/gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch
@@ -0,0 +1,16 @@
+Retrieved from
+https://github.com/NixOS/nixpkgs/raw/master/pkgs/development/libraries/qt-5/5.15/qtdeclarative-default-disable-qmlcache.patch
+
+diff --git a/src/qml/qml/qqmltypeloader.cpp b/src/qml/qml/qqmltypeloader.cpp
+index 1d66e75..827567a 100644
+--- a/src/qml/qml/qqmltypeloader.cpp
++++ b/src/qml/qml/qqmltypeloader.cpp
+@@ -727,7 +727,7 @@ bool QQmlTypeLoader::Blob::isDebugging() const
+
+ bool QQmlTypeLoader::Blob::diskCacheEnabled() const
+ {
+- return (!disableDiskCache() && !isDebugging()) || forceDiskCache();
++ return forceDiskCache();
+ }
+
+ bool QQmlTypeLoader::Blob::qmldirDataAvailable(const QQmlRefPointer<QQmlQmldirData> &data, QList<QQmlError> *errors)