aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fuzzylite-relative-path-in-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/fuzzylite-relative-path-in-tests.patch')
-rw-r--r--gnu/packages/patches/fuzzylite-relative-path-in-tests.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/fuzzylite-relative-path-in-tests.patch b/gnu/packages/patches/fuzzylite-relative-path-in-tests.patch
new file mode 100644
index 0000000000..1a03238246
--- /dev/null
+++ b/gnu/packages/patches/fuzzylite-relative-path-in-tests.patch
@@ -0,0 +1,15 @@
+Workaround https://github.com/fuzzylite/fuzzylite/issues/85
+
+diff --git a/fuzzylite/test/BenchmarkTest.cpp b/fuzzylite/test/BenchmarkTest.cpp
+index f868ec29..464d394d 100644
+--- a/fuzzylite/test/BenchmarkTest.cpp
++++ b/fuzzylite/test/BenchmarkTest.cpp
+@@ -30,7 +30,7 @@ namespace fl {
+ }
+
+ TEST_CASE("Benchmarks from FLD files", "[benchmark][fld]") {
+- std::string path = "../../examples/";
++ std::string path = "../examples/";
+ typedef std::pair<std::string, int > Example;
+ std::vector<Example> examples;
+ examples.push_back(Example("mamdani/AllTerms", int(1e4)));