aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b85c82b1ed..044da9290c 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -174,8 +174,8 @@
;; Note: the 'update-guix-package.scm' script expects this definition to
;; start precisely like this.
(let ((version "1.4.0")
- (commit "4dfdd822102690b5687acf28365ab707b68d9476")
- (revision 10))
+ (commit "d0438fcf658cb8c95b32381fac44b0a6278459ed")
+ (revision 11))
(package
(name "guix")
@@ -191,7 +191,7 @@
(commit commit)))
(sha256
(base32
- "1p21gz2lr7iqvma1m83k2r04w201rzvk31d5kfn2qkr9l0gds4cx"))
+ "05i32m7cxs7vhl54hvs0f9g84jhnn2dbc9qcgaqvqnqc4i8yhhxr"))
(file-name (string-append "guix-" version "-checkout"))))
(build-system gnu-build-system)
(arguments
@@ -515,6 +515,8 @@ $(prefix)/etc/openrc\n")))
("disarchive" ,disarchive) ;for 'guix perform-download'
("guile-lzma" ,guile-lzma) ;for Disarchive
+ ("git-minimal" ,git-minimal) ;for 'guix perform-download'
+
("glibc-utf8-locales" ,glibc-utf8-locales)))
(propagated-inputs
`(("guile-gnutls" ,guile-gnutls)
de'>git-authenticate: Store the sub-key fingerprint of mab....Ludovic Courtès 2020-02-20build-self: Show wider backtraces....Ludovic Courtès 2020-02-13git-authenticate: Add niedzejkob to the list of committers....Ludovic Courtès 2020-02-11git-authenticate: Add mab to the list of committers....Ludovic Courtès 2020-01-27git-authenticate: Add roptat's new key....Ludovic Courtès 2020-01-17git-authenticate: Adjust atheia's key info....Ludovic Courtès 2020-01-17git-authenticate: Add new key for atheia....Ludovic Courtès 2020-01-08git-authenticate: Add daviwil to the list of committers....Ludovic Courtès 2019-12-29git-authenticate: Add glv to the list of committers....Ludovic Courtès 2019-12-27git-authenticate: Keep a local cache of previously-authenticated commits....Ludovic Courtès 2019-12-27Add 'build-aux/git-authenticate.scm'....Ludovic Courtès 2019-12-01ci: Make sure the Guix checkout is the one providing Cuirass proc....Clément Lassieur 2019-11-13tests: "make check-system" uses Guix built with (guix self)....Ludovic Courtès 2019-10-16build: Remove references to 'NIX_LOCALSTATE_DIR'....Ludovic Courtès 2019-10-16daemon: Remove traces of 'NIX_ROOT_FINDER'....Ludovic Courtès 2019-09-08daemon: Remove 'NIX_LIBEXEC_DIR'....Ludovic Courtès 2019-09-08daemon: Run 'guix offload' directly....Ludovic Courtès 2019-09-08daemon: Invoke 'guix gc --list-busy' instead of 'list-runtime-roots'....Ludovic Courtès 2019-07-16Use more guix.gnu.org....Tobias Geerinckx-Rice 2019-06-25build: Report build errors via 'report-load-error'....Ludovic Courtès 2019-05-20maint: update-NEWS: Track "gcc-toolchain", not "gcc"....Ludovic Courtès 2019-05-16maint: 'check-available-binaries' checks for more packages....Ludovic Courtès 2019-05-12build-self: Let HOME pass through the execution environment....Ludovic Courtès 2019-05-11Revert "build-self: Let HOME pass through the execution environment."...Tobias Geerinckx-Rice 2019-05-11build-self: Let HOME pass through the execution environment....Ludovic Courtès