aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm53
1 files changed, 32 insertions, 21 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 3f3015bd80..b382043962 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -134,7 +134,7 @@
;; See <http://www.openldap.org/software/download/> for a list of
;; mirrors.
(uri (list (string-append
- "http://mirror.eu.oneandone.net/software/openldap"
+ "http://repository.linagora.org/OpenLDAP"
"/openldap-release/openldap-" version ".tgz")
(string-append
"https://www.openldap.org/software/download/OpenLDAP/"
@@ -146,25 +146,36 @@
(base32
"0ihddk8c6hg9lkjv0wk0w13g8kb75r8dfsn1n6b77mzk3pbs38nj"))))
(arguments
- (substitute-keyword-arguments (package-arguments openldap)
- ((#:phases phases)
- #~(modify-phases #$phases
- (replace 'patch-sasl-path
- ;; Give -L arguments for cyrus-sasl to avoid propagation.
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((krb5 (search-input-file inputs "/lib/libkrb5.so")))
- (substitute* (string-append #$output "/lib/libldap.la")
- (("-lkrb5" lib)
- (string-append "-L" (dirname krb5) "/lib " lib))))))
- (add-after 'install 'provide-ldap_r
- (lambda _
- ;; The re-entrant libldap_r no longer exists since 2.6
- ;; as it has become the default: provide a linker alias
- ;; for now.
- (call-with-output-file (string-append #$output
- "/lib/libldap_r.so")
- (lambda (port)
- (format port "INPUT ( libldap.so )~%")))))))))))
+ (list
+ #:tests? #f
+ #:configure-flags
+ #~'("--disable-static"
+ #$@(if (%current-target-system)
+ '("--with-yielding_select=yes"
+ "ac_cv_func_memcmp_working=yes")
+ '()))
+ #:phases
+ #~(modify-phases %standard-phases
+ #$@(if (%current-target-system)
+ '((add-before 'configure 'fix-cross-gcc
+ (lambda* (#:key target #:allow-other-keys)
+ (setenv "CC" (string-append target "-gcc"))
+ (setenv "STRIP" (string-append target "-strip")))))
+ '())
+ (add-after 'install 'provide-libldap_r
+ (lambda _
+ ;; The re-entrant libldap_r no longer exists since 2.6
+ ;; as it has become the default: provide a linker alias
+ ;; for now.
+ (call-with-output-file (string-append #$output
+ "/lib/libldap_r.so")
+ (lambda (port)
+ (format port "INPUT ( libldap.so )~%"))))))))
+ (synopsis "Implementation of the Lightweight Directory Access Protocol")
+ (description
+ "OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")
+ (license openldap2.8)
+ (home-page "https://www.openldap.org/")))
(define-public nss-pam-ldapd
(package
@@ -233,7 +244,7 @@ an LDAP server.")
(setenv "SLAPD" slapd)
(setenv "SCHEMA" schema)))))))
(inputs
- (list openldap-2.6 cyrus-sasl mit-krb5))
+ (list openldap cyrus-sasl mit-krb5))
(propagated-inputs
(list python-pyasn1 python-pyasn1-modules))
(home-page "https://www.python-ldap.org/")