aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm20
1 files changed, 6 insertions, 14 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 60247f34a2..5dc4c1baee 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -29,6 +29,7 @@
#:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system mozilla)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages bash)
@@ -49,7 +50,7 @@
(sha256
(base32
"177rxcf3lglabs7sgwcvf72ww4v56qa71lc495wl13sxs4f03vxy"))))
- (build-system gnu-build-system)
+ (build-system mozilla-build-system)
(inputs
(list perl ;for 'compile-et.pl'
bash-minimal)) ;for 'nspr-config'
@@ -69,16 +70,7 @@
#~(list "--disable-static"
"--enable-64bit"
(string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")
- ;; Mozilla deviates from Autotools conventions
- ;; due to historical reasons. Adjust to Mozilla conventions,
- ;; otherwise the Makefile will try to use TARGET-gcc
- ;; as a ‘native’ compiler.
- #$@(if (%current-target-system)
- #~((string-append "--host="
- #$(nix-system->gnu-triplet (%current-system)))
- (string-append "--target=" #$(%current-target-system)))
- #~()))
+ (assoc-ref %outputs "out") "/lib"))
;; Use fixed timestamps for reproducibility.
#:make-flags #~'("SH_DATE='1970-01-01 00:00:01'"
;; This is epoch 1 in microseconds.
@@ -126,7 +118,7 @@ in the Mozilla clients.")
(replacement nss/fixed)
;; Also update and test the nss-certs package, which duplicates version and
;; source to avoid a top-level variable reference & module cycle.
- (version "3.81")
+ (version "3.82")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -137,7 +129,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "19ncvhz45dhr0nmymwkxspq9l44gaafkspxiwxbqs1hpnqxmzgx8"))
+ "0wqmgibacxf5i3jlm8jl50qasv2spwx07ixlscz9byf2f8xnggrj"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-3.56-pkgconfig.patch"
"nss-getcwd-nonnull.patch"
@@ -200,7 +192,7 @@ in the Mozilla clients.")
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2022-06-01" "./nss/tests/all.sh"))
+ (invoke "faketime" "2022-09-01" "./nss/tests/all.sh"))
(format #t "test suite not run~%"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)