aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm152
1 files changed, 77 insertions, 75 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a5f0433652..e456b40a20 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -414,79 +414,76 @@ Android, and ChromeOS.")
(license license:lgpl2.1+)))
(define-public libnice
- ;; The latest release is old and randomly fails tests with GStreamer 1.18.5,
- ;; such as: "test-bind: ../libnice-0.1.18/stun/tests/test-bind.c:234:
- ;; bad_responses: Assertion `len >= 20' failed"
- (let ((revision "0")
- (commit "47a96334448838c43d7e72f4ef51b317befbfae1"))
- (package
- (name "libnice")
- (version (git-version "0.1.18" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.freedesktop.org/libnice/libnice")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19ypjazslmsb9vqs2wyyzvi72h5jbn16dbng7pxh485djdrmgcg4"))))
- (build-system meson-build-system)
- (outputs '("out" "doc"))
- (arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
- #:configure-flags
- (list
- "-Dgtk_doc=enabled")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- (substitute* "tests/meson.build"
- ;; ‘test-set-port-range.c:66:main: assertion failed:
- ;; (nice_agent_gather_candidates (agent, stream1))’
- (("'test-set-port-range'" all)
- (string-append "# " all))
- ;; The following test is disabled as it fails in a
- ;; nondeterministic fashion (see:
- ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/151).
- (("'test-bsd'" all)
- (string-append "# " all)))
- (substitute* "stun/tests/meson.build"
- ;; test-bind.c:234: bad_responses: Assertion `len >= 20'
- ;; failed (see:
- ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/150).
- (("'bind', ")
- ""))))
- (add-after 'install 'move-docs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc")))
- (mkdir-p (string-append doc "/share"))
- (rename-file
- (string-append out "/share/gtk-doc")
- (string-append doc "/share/gtk-doc"))))))))
- (native-inputs
- `(("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("graphviz" ,graphviz)
- ("gtk-doc" ,gtk-doc/stable)
- ("pkg-config" ,pkg-config)))
- (inputs
- (list gstreamer gst-plugins-base libnsl))
- (propagated-inputs
- (list glib glib-networking gnutls))
- (synopsis "GLib ICE implementation")
- (description "LibNice is a library that implements the Interactive
+ (package
+ (name "libnice")
+ (version "0.1.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libnice/libnice")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zxh1mdrl4p2vih8f4yqzm3pp4jsmc8aq7l43dlndaz4sj4c8j44"))))
+ (build-system meson-build-system)
+ (outputs '("out" "doc"))
+ (arguments
+ (list
+ #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ #~(list"-Dgtk_doc=enabled")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ (substitute* "tests/meson.build"
+ ;; ‘test-set-port-range.c:66:main: assertion failed:
+ ;; (nice_agent_gather_candidates (agent, stream1))’
+ (("'test-set-port-range'" all)
+ (string-append "# " all))
+ ;; The following test is disabled as it fails in a
+ ;; nondeterministic fashion (see:
+ ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/151).
+ (("'test-bsd'" all)
+ (string-append "# " all)))
+ (substitute* "stun/tests/meson.build"
+ ;; test-bind.c:234: bad_responses: Assertion `len >= 20'
+ ;; failed (see:
+ ;; https://gitlab.freedesktop.org/libnice/libnice/-/issues/150).
+ (("'bind', ")
+ ""))))
+ (add-after 'install 'move-docs
+ (lambda _
+ (mkdir-p (string-append #$output:doc "/share"))
+ (rename-file
+ (string-append #$output "/share/gtk-doc")
+ (string-append #$output:doc "/share/gtk-doc")))))))
+ (native-inputs
+ (list `(,glib "bin")
+ gobject-introspection
+ graphviz
+ gtk-doc/stable
+ pkg-config))
+ (inputs
+ (list gstreamer
+ gst-plugins-base
+ libnsl))
+ (propagated-inputs
+ (list glib
+ glib-networking
+ gnutls))
+ (synopsis "GLib ICE implementation")
+ (description "LibNice is a library that implements the Interactive
Connectivity Establishment (ICE) standard (RFC 5245 & RFC 8445). It provides a
GLib-based library, libnice, as well as GStreamer elements to use it.")
- (home-page "https://libnice.freedesktop.org/")
- (license
- ;; This project is dual-licensed.
- (list
- license:lgpl2.1+
- license:mpl1.1)))))
+ (home-page "https://libnice.freedesktop.org/")
+ (license
+ ;; This project is dual-licensed.
+ (list
+ license:lgpl2.1+
+ license:mpl1.1))))
(define-public librecast
(package
@@ -1199,7 +1196,7 @@ and SSH, and it can use both TCP and UDP as transport mechanisms.")
(define-public socat
(package
(name "socat")
- (version "1.7.4.1")
+ (version "1.7.4.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1207,7 +1204,7 @@ and SSH, and it can use both TCP and UDP as transport mechanisms.")
version ".tar.bz2"))
(sha256
(base32
- "1sbmqqvni3ss9wyay6ik5v81kxffkra80mh4ypgj74g82iba5b1z"))))
+ "01w0hpqf5xmgn40s1ablfd4y67dlrx5y9zlx24spc1qm8h81hwyl"))))
(build-system gnu-build-system)
(arguments '(#:tests? #f)) ; no test suite
(inputs (list openssl))
@@ -1612,7 +1609,7 @@ intended as a substitute for the PPPStatus and EthStatus projects.")
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)
("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml-5)
+ ("docbook-xml" ,docbook-xml)
("libxml2" ,libxml2) ;for XML_CATALOG_FILES
("xsltproc" ,libxslt)))
(inputs
@@ -2542,7 +2539,7 @@ sockets in Perl.")
(inputs
(list dbus zlib))
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -3819,6 +3816,11 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "tests/opendht_unit_tests"))))
+ (add-before 'bootstrap 'delete-autogen.sh
+ (lambda _
+ ;; The autogen.sh script lacks a shebang, cannot be executed
+ ;; directly. Let the bootstrap phase invoke autoreconf itself.
+ (delete-file "autogen.sh")))
(add-after 'install 'move-and-wrap-tools
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((tools (assoc-ref outputs "tools"))