aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm265
1 files changed, 167 insertions, 98 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5e0022ac76..133f525cb9 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
@@ -142,6 +142,35 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+(define-public usrsctp
+ (package
+ (name "usrsctp")
+ (version "0.9.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/sctplab/usrsctp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10ndzkip8blgkw572n3dicl6mgjaa7kygwn3vls80liq92vf1sa9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("which" ,which)))
+ (home-page "https://github.com/sctplab/usrsctp/")
+ (synopsis "SCTP user-land implementation")
+ (description "UsrSCTP is a portable SCTP userland stack. SCTP is a message
+oriented, reliable transport protocol with direct support for multihoming that
+runs on top of IP or UDP, and supports both v4 and v6 versions.")
+ (license license:bsd-3)))
+
(define-public axel
(package
(name "axel")
@@ -273,7 +302,7 @@ Android, and ChromeOS.")
(native-inputs
`(("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc)
+ ("gtk-doc" ,gtk-doc/stable)
("pkg-config" ,pkg-config)))
(inputs
`(("gstreamer" ,gstreamer)
@@ -813,7 +842,7 @@ useful for making transparent firewalls.")
(define-public socat
(package
(name "socat")
- (version "1.7.3.4")
+ (version "1.7.4.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -821,7 +850,7 @@ useful for making transparent firewalls.")
version ".tar.bz2"))
(sha256
(base32
- "1z7xgnwiqpcv1j6aghhj9nqbx7cg3gpc4n9j7vi9hm7nhv5788wp"))))
+ "1sbmqqvni3ss9wyay6ik5v81kxffkra80mh4ypgj74g82iba5b1z"))))
(build-system gnu-build-system)
(arguments '(#:tests? #f)) ; no test suite
(inputs `(("openssl" ,openssl)))
@@ -945,7 +974,7 @@ more.")
(define-public czmq
(package
(name "czmq")
- (version "4.2.0")
+ (version "4.2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -954,7 +983,7 @@ more.")
"/" name "-" version ".tar.gz"))
(sha256
(base32
- "1szciz62sk3fm4ga9qjpxz0n0lazvphm32km95bq92ncng12kayg"))))
+ "0fdclvd7fcwixp0k57ccv7d159v3slasyhvndxfn8n1a9hh0lwjx"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-drafts")
@@ -1312,7 +1341,7 @@ and up to 1 Mbit/s downstream.")
(define-public whois
(package
(name "whois")
- (version "5.5.7")
+ (version "5.5.8")
(source
(origin
(method git-fetch)
@@ -1321,7 +1350,7 @@ and up to 1 Mbit/s downstream.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1w3d0ffl0ng1m4i10k968kk4xicviq24w5vwl6d8dhja61d7yd2r"))))
+ (base32 "12lhl2q1pa1qkbv0l1cpy8hn4wh5i99bqc68rlm4f7jyqlj2l82r"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no test suite
@@ -1357,14 +1386,14 @@ of the same name.")
(define-public wireshark
(package
(name "wireshark")
- (version "3.4.3")
+ (version "3.4.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.wireshark.org/download/src/wireshark-"
version ".tar.xz"))
(sha256
- (base32 "0ar6pxzrcpxdriz437d6ziwlhb8k5wlvrkalp3hgqwzwy1vwqrzl"))))
+ (base32 "0aad3m8nh4i75dgjs68217135bzqmhmlgjklmpjh1ihmjwgd373j"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -1454,13 +1483,13 @@ round-robin fashion.")
(define-public gandi.cli
(package
(name "gandi.cli")
- (version "1.5")
+ (version "1.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
- (base32 "110wc9zgxsrvw4yzp21p0ian5lcf7vhcpxhnmsc4fg9pzl2bwxd5"))))
+ (base32 "1h36jahbp7273wn3yd747kbiwjc0bm3sja67bcxdsd54ln0vyndg"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1484,8 +1513,11 @@ round-robin fashion.")
#t))))))
(native-inputs
`(("python-docutils" ,python-docutils) ; for rst2man.py
+ ("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
("python-tox" ,python-tox)))
+ (propagated-inputs
+ `(("openssh" ,openssh))) ; used by gandi/cli/modules/iass.py
(inputs
`(("openssl" ,openssl)
("python-click" ,python-click)
@@ -1627,14 +1659,14 @@ TCP connection, TLS handshake and so on) in the terminal.")
(define-public squid
(package
(name "squid")
- (version "4.13")
+ (version "4.14")
(source
(origin
(method url-fetch)
(uri (string-append "http://www.squid-cache.org/Versions/v4/squid-"
version ".tar.xz"))
(sha256
- (base32 "1q1ywpic6s7dfjj3cwzcfgscc4zq0aih462gyas7j1z683ss14b8"))))
+ (base32 "1z4zf98q24ps19fq840n0hwh6z1la65rf061kcapr29lcjm7s2gi"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -1863,7 +1895,7 @@ loop.")
(define-public perl-data-validate-ip
(package
(name "perl-data-validate-ip")
- (version "0.27")
+ (version "0.30")
(source
(origin
(method url-fetch)
@@ -1871,7 +1903,7 @@ loop.")
"mirror://cpan/authors/id/D/DR/DROLSKY/Data-Validate-IP-"
version ".tar.gz"))
(sha256
- (base32 "1mmppyzsh1w2z2h86kvzqxy56wxgs62a3kf8nvcnz76bblir5ap1"))))
+ (base32 "074adrlvkiahj1fdc9nvb95dpfyjzm2jzhi90m8xaw4bw5ipcbzy"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-requires" ,perl-test-requires)))
@@ -1890,7 +1922,7 @@ private (reserved).")
(define-public perl-net-dns
(package
(name "perl-net-dns")
- (version "1.28")
+ (version "1.30")
(source
(origin
(method url-fetch)
@@ -1901,7 +1933,7 @@ private (reserved).")
(string-append "mirror://cpan/authors/id/N/NL/NLNETLABS/Net-DNS-"
version ".tar.gz")))
(sha256
- (base32 "0kh2qbhxv005pqb35mdk2bld7cg7xnxl12qvdwv30sgd91aqica7"))))
+ (base32 "1nm560xjg173wvv736ai3ib1gwssyy41gi0yv4j5fqamfav70ph5"))))
(build-system perl-build-system)
(inputs
`(("perl-digest-hmac" ,perl-digest-hmac)))
@@ -2066,22 +2098,19 @@ It is intended primarily for use in testing.")
(define-public perl-net-cidr-lite
(package
(name "perl-net-cidr-lite")
- (version "0.21")
+ (version "0.22")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/D/DO/DOUGW/Net-CIDR-Lite-"
+ "mirror://cpan/authors/id/S/ST/STIGTSP/Net-CIDR-Lite-"
version
".tar.gz"))
(sha256
- (base32
- "14shj73zbqmfjbp0qz1fs9j4p2dpvz5hfkm4qfdjbydflbl2b8fg"))))
+ (base32 "05w57db2lx4djb4vixzdr6qgrzyzkk047nl812g7nq8s6k5xh5s3"))))
(build-system perl-build-system)
- (home-page
- "https://metacpan.org/release/Net-CIDR-Lite")
- (synopsis
- "Perl extension for merging IPv4 or IPv6 CIDR addresses")
+ (home-page "https://metacpan.org/release/Net-CIDR-Lite")
+ (synopsis "Perl extension for merging IPv4 or IPv6 CIDR addresses")
(description "Net::CIDR::Lite merges IPv4 or IPv6 CIDR addresses.")
(license license:gpl1+)))
@@ -2387,7 +2416,7 @@ procedure calls (RPCs).")
(define-public openvswitch
(package
(name "openvswitch")
- (version "2.13.0")
+ (version "2.13.3")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2395,7 +2424,7 @@ procedure calls (RPCs).")
version ".tar.gz"))
(sha256
(base32
- "0cd5vmfr6zwgcnkwys6rag6cmz68v0librpaplianv734xs74pyx"))))
+ "1wc5zspy9aln7di7m9a1qy4lv3h05gmhgd1nffhb9nxdcxqgnpgp"))))
(build-system gnu-build-system)
(arguments
'(;; FIXME: many tests fail with:
@@ -2592,8 +2621,9 @@ does not use SSH and requires a pre-shared symmetric key.")
(version "1.2.4")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/quagga/quagga-"
- version ".tar.gz"))
+ ;; Use archived sources; see <http://issues.guix.gnu.org/47123>.
+ (uri (string-append "https://fossies.org/linux/misc/"
+ "quagga-" version ".tar.gz"))
(sha256
(base32
"1lsksqxij5f1llqn86pkygrf5672kvrqn1kvxghi169hqf1c0r73"))
@@ -2900,7 +2930,7 @@ remotely.")
(define-public zyre
(package
(name "zyre")
- (version "2.0.0")
+ (version "2.0.1")
(source (origin
(method url-fetch)
(uri
@@ -2908,7 +2938,7 @@ remotely.")
version "/" name "-" version ".tar.gz"))
(sha256
(base32
- "0qz2730bng1gs9xbqxhkw88qbsmszgmmrl2g9k6xrg6r3bqvsdc7"))))
+ "13596507ma1474cjqzxym5jlvcshvw7sjhw80rdz788gyz6kz90b"))))
(build-system gnu-build-system)
(inputs `(("zeromq" ,zeromq)
("czmq" ,czmq)
@@ -2994,7 +3024,8 @@ eight bytes) tools
;; Either BSD-3 or GPL-2 can be used.
(license (list license:bsd-3 license:gpl2))))
-(define-public asio
+;;; This is an old version required by rested.
+(define-public asio-1.12
(package
(name "asio")
(version "1.12.2")
@@ -3021,6 +3052,18 @@ low-level I/O programming that provides developers with a consistent
asynchronous model using a modern C++ approach.")
(license license:boost1.0)))
+(define-public asio
+ (package
+ (inherit asio-1.12)
+ (version "1.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/asio/asio/"
+ version " (Stable)/asio-" version ".tar.bz2"))
+ (sha256
+ (base32 "04wi69d72l1p5c7d63z1dz06zn8pdqsbgx1if98dszs9ymfqgyaa"))))))
+
(define-public shadowsocks
;; There are some security fixes after the last release.
(let* ((commit "e332ec93e9c90f1cbee676b022bf2c5d5b7b1239")
@@ -3286,62 +3329,61 @@ never see any machines other than the one Dante is running on.")
(license (license:non-copyleft "file://LICENSE"))))
(define-public restbed
- (let ((commit "6eb385fa9051203f28bf96cc1844bbb5a9a6481f"))
- (package
- (name "restbed")
- (version (git-version "4.6" "1" commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Corvusoft/restbed/")
- (commit commit)))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0k60i5drklqqrb4khb25fzkgz9y0sncxf1sp6lh2bm1m0gh0661n"))))
- (build-system cmake-build-system)
- (inputs
- `(("asio" ,asio)
- ("catch" ,catch-framework)
- ("openssl" ,openssl)))
- (arguments
- `(#:tests? #f
- #:configure-flags
- '("-DBUILD_TESTS=NO"
- "-DBUILD_EXAMPLES=NO"
- "-DBUILD_SSL=NO"
- "-DBUILD_SHARED=NO")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'apply-patches-and-fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((asio (assoc-ref inputs "asio"))
- (catch (assoc-ref inputs "catch"))
- (openssl (assoc-ref inputs "openssl")))
- (substitute* "cmake/Findasio.cmake"
- (("(find_path\\( asio_INCLUDE asio\\.hpp HINTS ).*$" all begin)
- (string-append begin " \"" asio "/include\" )")))
- (substitute* "cmake/Findcatch.cmake"
- (("(find_path\\( catch_INCLUDE catch\\.hpp HINTS ).*$" all begin)
- (string-append begin " \"" catch "/include\" )")))
- (substitute* "cmake/Findopenssl.cmake"
- (("(find_library\\( ssl_LIBRARY ssl ssleay32 HINTS ).*$" all begin)
- (string-append begin " \"" openssl "/lib\" )"))
- (("(find_library\\( crypto_LIBRARY crypto libeay32 HINTS ).*$" all begin)
- (string-append begin " \"" openssl "/lib\" )"))
- (("(find_path\\( ssl_INCLUDE openssl/ssl\\.h HINTS ).*$" all begin)
- (string-append begin " \"" openssl "/include\" )")))))))))
- (synopsis "Asynchronous RESTful functionality to C++11 applications")
- (description "Restbed is a comprehensive and consistent programming
+ (package
+ (name "restbed")
+ (version "4.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Corvusoft/restbed/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "055qicb773a599dsqbcz5xf0xj1wpk33mdrkyi0fsmyjmn8d2p9d"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("asio" ,asio-1.12)
+ ("catch" ,catch-framework)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ '("-DBUILD_TESTS=NO"
+ "-DBUILD_EXAMPLES=NO"
+ "-DBUILD_SSL=NO"
+ "-DBUILD_SHARED=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'apply-patches-and-fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((asio (assoc-ref inputs "asio"))
+ (catch (assoc-ref inputs "catch"))
+ (openssl (assoc-ref inputs "openssl")))
+ (substitute* "cmake/Findasio.cmake"
+ (("(find_path\\( asio_INCLUDE asio\\.hpp HINTS ).*$" all begin)
+ (string-append begin " \"" asio "/include\" )")))
+ (substitute* "cmake/Findcatch.cmake"
+ (("(find_path\\( catch_INCLUDE catch\\.hpp HINTS ).*$" all begin)
+ (string-append begin " \"" catch "/include\" )")))
+ (substitute* "cmake/Findopenssl.cmake"
+ (("(find_library\\( ssl_LIBRARY ssl ssleay32 HINTS ).*$" all begin)
+ (string-append begin " \"" openssl "/lib\" )"))
+ (("(find_library\\( crypto_LIBRARY crypto libeay32 HINTS ).*$" all begin)
+ (string-append begin " \"" openssl "/lib\" )"))
+ (("(find_path\\( ssl_INCLUDE openssl/ssl\\.h HINTS ).*$" all begin)
+ (string-append begin " \"" openssl "/include\" )")))))))))
+ (synopsis "Asynchronous RESTful functionality to C++11 applications")
+ (description "Restbed is a comprehensive and consistent programming
model for building applications that require seamless and secure
communication over HTTP.")
- (home-page "https://github.com/Corvusoft/restbed")
- (license license:agpl3+))))
+ (home-page "https://github.com/Corvusoft/restbed")
+ (license license:agpl3+)))
(define-public restinio
(package
(name "restinio")
- (version "0.6.1.1")
+ (version "0.6.13")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3350,7 +3392,7 @@ communication over HTTP.")
(file-name (git-file-name name version))
(sha256
(base32
- "141a96hx8zhcdv121g6cs91n46kb47y040v25pnvz5f54964z7f5"))))
+ "0gb0yc88hdzwm08zdiviay6s08q427za33kfbygib7bdzp2wr2dm"))))
(build-system cmake-build-system)
(inputs ; TODO: Need to force-keep references on some inputs, e.g. boost.
`(("zlib" ,zlib)
@@ -3383,40 +3425,39 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(define-public opendht
(package
(name "opendht")
- (version "2.1.4")
+ (version "2.2.0rc4") ;jami requires >= 2.2.0
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/savoirfairelinux/opendht")
(commit version)))
(file-name (git-file-name name version))
- (patches (search-patches "opendht-fix-jami.patch"))
(sha256
(base32
- "1ax26ri1ifb6s8ppd28jmanka9yf8mw3np65q2h4djhhik0phhal"))))
+ "1wc0f6cnvnlmhxnx64nxqgsx93k4g7ljdaqjl40ml74jg3nqrzcl"))))
;; Since 2.0, the gnu-build-system does not seem to work anymore, upstream bug?
(build-system cmake-build-system)
(inputs
`(("argon2" ,argon2)
- ("nettle" ,nettle)
+ ("nettle" ,nettle-3.7)
("readline" ,readline)
("jsoncpp" ,jsoncpp)
("openssl" ,openssl) ;required for the DHT proxy
("fmt" ,fmt)))
(propagated-inputs
`(("gnutls" ,gnutls) ;included in opendht/crypto.h
- ("msgpack" ,msgpack))) ;included in several installed headers
+ ("msgpack" ,msgpack) ;included in several installed headers
+ ("restinio" ,restinio))) ;included in opendht/http.h
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("pkg-config" ,pkg-config)
- ("restinio" ,restinio) ;headers only library
("libtool" ,libtool)
("cppunit" ,cppunit)))
(arguments
`(#:tests? #f ; Tests require network connection.
#:configure-flags
- '(;; "-DOPENDHT_TESTS=on"
+ '(;;"-DOPENDHT_TESTS=on"
"-DOPENDHT_TOOLS=off"
"-DOPENDHT_PYTHON=off"
"-DOPENDHT_PROXY_SERVER=on"
@@ -3433,7 +3474,7 @@ communication.")
(define-public frrouting
(package
(name "frrouting")
- (version "6.0.2")
+ (version "7.5")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/FRRouting/frr/releases/"
@@ -3441,11 +3482,13 @@ communication.")
".tar.xz"))
(sha256
(base32
- "0xfrvi62w8qlh46f504ka0skb7pm0g0p8vmdng4w90gsbirlzpdd"))))
+ "1a27wvxmc51sr0kchy0hjfpv19imlgrr3s9k48lik9k01g71yrdr"))))
(build-system gnu-build-system)
(inputs
`(("c-ares" ,c-ares)
("json-c" ,json-c)
+ ("libcap" ,libcap)
+ ("libyang" ,libyang)
("readline" ,readline)))
(native-inputs
`(("perl" ,perl)
@@ -3516,6 +3559,33 @@ libraries and instead utilizing features provided by the Linux kernel to the
maximum extent possible.")
(license license:lgpl2.1+)))
+(define-public libyang
+ (package
+ (name "libyang")
+ (version "1.0.215")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CESNET/libyang")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mrs2ppmq77z8sbqgm2w0rl9bfgybd6bcxanakfww4chih6cy0dw"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "-DENABLE_BUILD_TESTS=ON" "-DENABLE_LYD_PRIV=ON")))
+ (propagated-inputs `(("pcre" ,pcre)))
+ (native-inputs `(("cmocka" ,cmocka)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/CESNET/libyang")
+ (synopsis "YANG data modelling language library")
+ (description "libyang is a YANG data modelling language parser and toolkit
+written (and providing API) in C. Current implementation covers YANG 1.0 (RFC
+6020) as well as YANG 1.1 (RFC 7950).")
+ (license license:bsd-3)))
+
(define-public batctl
(package
(name "batctl")
@@ -3764,14 +3834,14 @@ thousands of connections is clearly realistic with today's hardware.")
(define-public lldpd
(package
(name "lldpd")
- (version "1.0.8")
+ (version "1.0.9")
(source
(origin
(method url-fetch)
(uri (string-append "https://media.luffy.cx/files/lldpd/lldpd-"
version ".tar.gz"))
(sha256
- (base32 "1vrxr8lgkw7q6ixaaili6ac7i0j0326194s498n2dxihdvkh1llq"))
+ (base32 "1xa9953hl2c94zi4ngaxyi2yw3dax1ab16118wriwawm4lqynr3b"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3881,7 +3951,7 @@ network.")
(define-public yggdrasil
(package
(name "yggdrasil")
- (version "0.3.15")
+ (version "0.3.16")
(source
(origin
(method git-fetch)
@@ -3892,8 +3962,7 @@ network.")
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32
- "0gk7gy8yq5nrnblv4imxzzm2hac4ri0hlw19ajfbc1zll5kj32gf"))
+ (base32 "0vyd7a333hwn6j1lv1g9sicw74a4qk982bsi3cfdhjlv6hsjwmil"))
(patches (search-patches "yggdrasil-extra-config.patch"))))
(build-system go-build-system)
(arguments