aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/matrix.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/matrix.scm')
-rw-r--r--gnu/packages/matrix.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 6107dfc979..32ae62fcb4 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -171,6 +171,13 @@ homeserver and generally help bootstrap the ecosystem.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; Remove upper bounds of cachetool pin.
+ (("cachetools (.*version = )\"\\^4" _ match)
+ (string-append "cachetools " match
+ "\">=4")))))
(add-before 'check 'install-tests
(lambda* (#:key inputs outputs #:allow-other-keys)
(copy-recursively (string-append