aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index f9e9759cf2..fcd5c2e1c7 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -69,7 +69,8 @@
(lambda _
(setenv "LSOF_CC" "gcc")
(setenv "LSOF_MAKE" "make")
- (zero? (system* "./Configure" "linux"))))
+ (invoke "./Configure" "linux")
+ #t))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
bot-nginx-server-configurations): Don't return a broken nginx-server-configuration with empty server_name when no certificate domains are configured. Instead add a separate server for every certificate, so 0 certificates adds 0 servers. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Reviewed-by: Bruno Victal <mirai@makinata.eu> Saku Laesvuori 2023-01-03services: certbot: Fix broken link....* gnu/services/certbot.scm (certbot-renewal-jobs): Fix broken link. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> jgart 2022-09-29services: certbot: Create "live" directory during activation....When trying to run certbot, the mcron command fails, as /etc/letsencrypt/live is missing. This patch adds it into the certbot activation service. * gnu/services/certbot.scm (certbot-activation): Make /etc/letsencrypt/live. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Mája Tomášek 2021-06-24services: certbot: Add option to use CSR file....* gnu/services/certbot.scm (<certificate-configuration>): Add csr field. (certbot-command): Modify. * doc/guix.texi (Certificate Services): Document it. Raghav Gururajan