aboutsummaryrefslogtreecommitdiff
-rw-r--r--
gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 28958a54e2..64b8405014 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -422,7 +422,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-4.14)))
-(define-public linux-libre-4.9-version "4.9.259")
+(define-public linux-libre-4.9-version "4.9.260")
(define deblob-scripts-4.9
(linux-libre-deblob-scripts
linux-libre-4.9-version
@@ -430,7 +430,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0fxajshb75siq39lj5h8xvhdj8lcmddkslwlyj65rhlwk6g2r4b2")))
(define-public linux-libre-4.9-pristine-source
(let ((version linux-libre-4.9-version)
- (hash (base32 "1r71vgbw17srsjdmsdr1jra7v412mhiysi4kpa77y29r2h3zk5r3")))
+ (hash (base32 "1xcgqvk1g3l9bidpx377rbbwzvyxb0sbkszlk722bj7vk6c4asmq")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-4.9)))
(bytevector=? hash (comparison-report-local-sha256 report)) (match (comparison-report-narinfos report) ((bad) (bytevector=? wrong-hash (narinfo-hash->sha256 (narinfo-hash bad)))))))))))))))) (test-assertm "inconclusive: no substitutes" (mlet* %store-monad ((drv (gexp->derivation "foo" #~(mkdir #$output))) (out -> (derivation->output-path drv)) (_ (built-derivations (list drv))) (hash (query-path-hash* out))) (>>= (compare-contents (list out) (%test-substitute-urls)) (match-lambda ((report) (return (and (string=? out (comparison-report-item report)) (comparison-report-inconclusive? report) (null? (comparison-report-narinfos report)) (bytevector=? (comparison-report-local-sha256 report) hash)))))))) (test-assertm "inconclusive: no local build" (let ((text (random-text))) (mlet* %store-monad ((drv (gexp->derivation "something" #~(list #$output #$text))) (out -> (derivation->output-path drv)) (hash -> (gcrypt:sha256 #vu8()))) (with-derivation-narinfo* drv (sha256 => hash) (>>= (compare-contents (list out) (%test-substitute-urls)) (match-lambda ((report) (return (and (string=? out (comparison-report-item report)) (comparison-report-inconclusive? report) (not (comparison-report-local-sha256 report)) (match (comparison-report-narinfos report) ((narinfo) (bytevector=? (narinfo-hash->sha256 (narinfo-hash narinfo)) hash)))))))))))) (define (make-narinfo item size hash) (format #f "StorePath: ~a Compression: none URL: nar/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa-foo NarSize: ~d NarHash: sha256:~a References: ~%" item size (bytevector->nix-base32-string hash))) (define (call-mismatch-test proc) "Pass PROC a <comparison-report> for a mismatch and return its return value." ;; Pretend we have two different results for the same store item, ITEM, with ;; "/bin/guile" differing between the two nars. (mlet* %store-monad ((drv1 (package->derivation %bootstrap-guile)) (drv2 (gexp->derivation "broken-guile" (with-imported-modules '((guix build utils)) #~(begin (use-modules (guix build utils)) (copy-recursively #$drv1 #$output) (chmod (string-append #$output "/bin/guile") #o755) (call-with-output-file (string-append #$output "/bin/guile") (lambda (port) (display "corrupt!" port))))))) (out1 -> (derivation->output-path drv1)) (out2 -> (derivation->output-path drv2)) (item -> (string-append (%store-prefix) "/" (bytevector->nix-base32-string (random-bytevector 32)) "-foo" (number->string (current-time) 16)))) (mbegin %store-monad (built-derivations (list drv1 drv2)) (mlet* %store-monad ((size1 (query-path-size out1)) (size2 (query-path-size out2)) (hash1 (query-path-hash* out1)) (hash2 (query-path-hash* out2)) (nar1 -> (call-with-bytevector-output-port (lambda (port) (write-file out1 port)))) (nar2 -> (call-with-bytevector-output-port (lambda (port) (write-file out2 port))))) (parameterize ((%http-server-port 9000)) (with-http-server `((200 ,(make-narinfo item size1 hash1)) (200 ,nar1)) (parameterize ((%http-server-port 9001)) (with-http-server `((200 ,(make-narinfo item size2 hash2)) (200 ,nar2)) (mlet* %store-monad ((urls -> (list (%local-url 9000) (%local-url 9001))) (reports (compare-contents (list item) urls))) (pk 'report reports) (return (proc (car reports)))))))))))) (test-assertm "differing-files" (call-mismatch-test (lambda (report) (equal? (differing-files report) '("/bin/guile"))))) (test-assertm "call-with-mismatches" (call-mismatch-test (lambda (report) (call-with-mismatches report (lambda (directory1 directory2) (let* ((files1 (find-files directory1)) (files2 (find-files directory2)) (files (map (cute string-drop <> (string-length directory1)) files1))) (and (equal? files (map (cute string-drop <> (string-length directory2)) files2)) (equal? (remove (lambda (file) (file=? (string-append directory1 "/" file) (string-append directory2 "/" file))) files) '("/bin/guile"))))))))) (test-end) ;;; Local Variables: ;;; eval: (put 'with-derivation-narinfo* 'scheme-indent-function 2) ;;; End: