aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 23c1adf650..4a05842c9f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -370,7 +370,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.10-version "5.10.24")
+(define-public linux-libre-5.10-version "5.10.25")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
linux-libre-5.10-version
@@ -378,7 +378,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0hh27ccqimagr3aij7ygwikxw66y63sqwd0xlf49bhpjd090r9a7")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "0gvnplip90gvlzw9rm0cg66z54cfa82gk23icf5xdickb17d1p66")))
+ (hash (base32 "1p8s8vp5b6vjmvhj3plm0pr0d9qp5lrwm6l40a4bjr1vk9myf2lk")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
utify = { webkit: false, } input: { console.log(function() { 1 + 1; }.a = 1); } expect_exact: "console.log(function(){1+1}.a=1);" expect_stdout: "1" } lambda_dot_assign_webkit: { beautify = { webkit: true, } input: { console.log(function() { 1 + 1; }.a = 1); } expect_exact: "console.log((function(){1+1}).a=1);" expect_stdout: "1" } lambda_name_mangle: { mangle = {} input: { console.log(typeof function foo(bar) {}); } expect_exact: "console.log(typeof function o(n){});" expect_stdout: "function" } lambda_name_mangle_ie8: { mangle = { ie8: true, toplevel: true, } input: { console.log(typeof function foo(bar) {}); } expect_exact: "console.log(typeof function n(o){});" expect_stdout: "function" } function_name_mangle: { options = { keep_fnames: true, reduce_vars: true, unused: true, } mangle = {} input: { (function() { function foo(bar) {} console.log(typeof foo); })(); } expect_exact: "(function(){console.log(typeof function o(n){})})();" expect_stdout: "function" } function_name_mangle_ie8: { options = { keep_fnames: true, reduce_vars: true, unused: true, } mangle = { ie8: true, toplevel: true, } input: { (function() { function foo(bar) {} console.log(typeof foo); })(); } expect_exact: "(function(){console.log(typeof function n(o){})})();" expect_stdout: "function" }