aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index d2bf5b015b..714072e84b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1102,7 +1102,8 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
("flex" ,flex)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)
- ("which" ,which)))
+ ("which" ,which)
+ ("ziptime" ,ziptime)))
(inputs
`(("bluez" ,bluez)
("boost" ,boost)
@@ -1216,6 +1217,13 @@ converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
"/bin/xdg-open")))
#t))
+ (add-after 'install 'reset-zip-timestamps
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file)
+ (invoke "ziptime" file))
+ ;; So many different extensions for .zip files.
+ (find-files out "\\.(bau|dat|otp|ott|zip)$")))))
(add-after 'install 'bin-and-desktop-install
;; Create 'soffice' and 'libreoffice' symlinks to the executable
;; script.
tem....Jonathan Scoresby 2023-11-03gnu: msmtp: Update to 1.8.25....Timotej Lazar 2023-10-29gnu: opensmtpd: Update to 7.4.0p0 (bis)....Tobias Geerinckx-Rice 2023-10-29Revert "gnu: opensmtpd: Update to 7.4.0p0."...Tobias Geerinckx-Rice 2023-10-22gnu: opensmtpd: Update to 7.4.0p0....Tobias Geerinckx-Rice 2023-10-23gnu: public-inbox: Remove dependency on (guix build syscalls)....Ludovic Courtès 2023-10-22gnu: go-github-com-stretchr-testify: Move to (gnu packages golang-check)....Sharlatan Hellseher 2023-10-09gnu: isync: Patch path to openssl binary....Efraim Flashner 2023-10-06gnu: exim: Update to 4.96.1 [security updates]....Wilko Meyer 2023-09-24gnu: opensmtpd: Update to 7.3.0p2 [security fixes]....Tobias Geerinckx-Rice 2023-09-25gnu: muchsync: Update to 7....Hendursaga 2023-09-22Merge branch 'master' into emacs-teamLiliana Marie Prikler 2023-09-10gnu: mutt: Update to 2.2.12 [security fixes]....André Batista 2023-09-10gnu: mu: Update to 1.10.7....Tobias Geerinckx-Rice 2023-09-10gnu: dovecot-pigeonhole: Update to 0.5.21....Tobias Geerinckx-Rice 2023-09-10gnu: dovecot: Update to 2.3.21....Tobias Geerinckx-Rice 2023-09-09Merge branch 'master' into emacs-teamLiliana Marie Prikler 2023-09-06gnu: gmime: Update home-page URL....Maxim Cournoyer 2023-09-05gnu: gmime: Remove version 2.6.23....宋文武 2023-08-26Merge branch 'master' into emacs-teamLiliana Marie Prikler 2023-08-15gnu: notmuch: Fix tests with Emacs 29....Arjan Adriaanse 2023-08-06gnu: Remove duplicate import in (gnu packages mail)....Tobias Geerinckx-Rice 2023-08-06gnu: rspamd: Sort inputs....Tobias Geerinckx-Rice 2023-08-06gnu: rspamd: Update to 3.6....Tobias Geerinckx-Rice 2023-09-04gnu: mumi: Update to 0.0.5-3.2453a5a....Arun Isaac 2023-08-26gnu: neomutt: Update to 20230517....flabbergasted