aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 00d5eb049d..83bf7bd95a 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -457,9 +457,8 @@ GZip format, via a subclass of QIODevice.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "TZ" "Europe/Prague")
(setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
- #t)))))
+ (search-input-directory inputs
+ "share/zoneinfo")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for interfacing with calendars")
(description "This library provides access to and handling of calendar
@@ -1647,8 +1646,7 @@ integrated it into your application's other widgets.")
;; Xvfb doesn't have proper glx support and needs a pixeldepth
;; of 24 bit to avoid "libGL error: failed to load driver: swrast"
;; "Could not initialize GLX"
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 -screen 0 640x480x24 &"))
+ (system "Xvfb :1 -screen 0 640x480x24 &")
(setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
@@ -2392,8 +2390,7 @@ their settings.")
(lambda* (#:key inputs #:allow-other-keys)
;; The test suite requires a running X server, setting
;; QT_QPA_PLATFORM=offscreen does not suffice.
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 -screen 0 640x480x24 &"))
+ (system "Xvfb :1 -screen 0 640x480x24 &")
(setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
@@ -3697,8 +3694,8 @@ workspace.")
(lambda* (#:key inputs tests? #:allow-other-keys)
(setenv "HOME" (getcwd))
(setenv "TZDIR" ; KDateTimeTestsome needs TZDIR
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
+ (search-input-directory inputs
+ "share/zoneinfo"))
;; Make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
;; enable debug output
u/packages/astronomy.scm?id=6fd52309b8f52c9bb59fccffac53e029ce94b698'>gnu: Use HTTPS for almost all gnu.org HOME-PAGEs.Tobias Geerinckx-Rice 2017-03-20gnu: Add comments on why setting QT_QPA_PLATFORM for tests.Hartmut Goebel 2017-03-04gnu: stellarium: Use modular Qt.Danny Milosavljevic 2017-03-03gnu: stellarium: Fix package formatting.Danny Milosavljevic 2017-03-02gnu: Merge the two stellaria into one.John Darrington 2017-03-02gnu: Add stellarium.John Darrington 2017-01-15gnu: wcslib: Update to 5.16.Tobias Geerinckx-Rice 2016-10-08gnu: gnuastro: Update to 0.2.Efraim Flashner 2016-09-12gnu: (cfitsio, wcslib): Change return values of custom phases.John Darrington 2016-08-31gnu: wcslib: Correct formatting and grammar.John Darrington 2016-08-31gnu: Add gnuastroJohn Darrington 2016-08-31gnu: Add wcslibJohn Darrington 2016-08-31gnu: Add cfitsioJohn Darrington