aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index d800f861df..b068dee61f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2519,6 +2519,19 @@ update step.")
(sha256
(base32 "16k1r02w5qivvr99n5a9impbnnzygpj705irf5ypy208np91xyyd"))))
(build-system julia-build-system)
+ (arguments
+ (list
+ #:phases
+ (if (target-aarch64?)
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-some-tests
+ (lambda _
+ (substitute* "test/lapack.jl"
+ (("@testset.*stedc.*" all)
+ (string-append all "return\n"))
+ (("@testset.*stemr.*" all)
+ (string-append all "return\n"))))))
+ #~%standard-phases)))
(native-inputs
(list julia-quaternions))
(home-page "https://github.com/JuliaLinearAlgebra/GenericLinearAlgebra.jl")
llenge): Add an explicit 'exit' call when ISSUES is empty. * scripts/guix.in: Add comment about 'exit'. * doc/guix.texi (Invoking guix challenge): Mention the behavior and exit code. Ludovic Courtès