aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm123
1 files changed, 53 insertions, 70 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 228a31c7d0..9f14a06e89 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -566,28 +566,27 @@ extracting icontainer icon files.")
(define-public libtiff
(package
(name "libtiff")
- (version "4.3.0")
+ (version "4.4.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.osgeo.org/libtiff/tiff-"
- version ".tar.gz"))
+ version ".tar.xz"))
+ (patches (search-patches "libtiff-CVE-2022-34526.patch"))
(sha256
(base32
- "1j3snghqjbhwmnm5vz3dr1zm68dj15mgbx1wqld7vkl7n2nfaihf"))))
+ "1h8xrcpbyf9id2hw2ms0cmpgx0li8gladjzj82ycgk28018pnc29"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.8 MiB of HTML documentation
(arguments
- ;; Instead of using --docdir, this package has its own --with-docdir.
- `(#:configure-flags
- (list (string-append "--with-docdir="
- (assoc-ref %outputs "doc")
- "/share/doc/"
- ,name "-" ,(package-version this-package))
- "--disable-static")))
- (inputs `(("zlib" ,zlib)
- ("libjpeg" ,libjpeg-turbo)))
+ (list #:configure-flags
+ ;; Instead of using --docdir, this package has its own --with-docdir.
+ #~(list (string-append "--with-docdir=" #$output:doc "/share/doc/"
+ #$name "-" #$(package-version this-package))
+ "--disable-static")))
+ (inputs
+ (list libjpeg-turbo xz zlib))
(synopsis "Library for handling TIFF files")
(description
"Libtiff provides support for the Tag Image File Format (TIFF), a format
@@ -596,6 +595,8 @@ Included are a library, libtiff, for reading and writing TIFF and a small
collection of tools for doing simple manipulations of TIFF images.")
(license (license:non-copyleft "file://COPYRIGHT"
"See COPYRIGHT in the distribution."))
+ (properties
+ '((upstream-name . "tiff")))
(home-page "http://www.simplesystems.org/libtiff/")))
(define-public leptonica
@@ -668,26 +669,12 @@ arithmetic ops.")
(base32
"0dwa24kjqyg9hmm40fh048sdxfpnasz43l2rm8wlkw1qbdlpd517"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--disable-static")
- #:phases (modify-phases %standard-phases
- (add-before 'bootstrap 'force-bootstrap
- (lambda _
- ;; XXX: jbig2dec 0.18 was released with
- ;; a broken configure script, so we
- ;; recreate the build system here.
- ;; Remove the autoconf inputs below
- ;; when deleting this code.
- (delete-file "configure")
- (delete-file "autogen.sh")
- #t)))))
+ (arguments '(#:configure-flags '("--disable-static")))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("python" ,python-minimal-wrapper))) ;for tests
+ (list python-minimal-wrapper)) ;for tests
(synopsis "Decoder of the JBIG2 image compression format")
(description
- "JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit
+ "JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit
monochrome) images at moderately high resolution, and in particular scanned
paper documents. In this domain it is very efficient, offering compression
ratios on the order of 100:1.
@@ -777,17 +764,17 @@ images of initially unknown height.")
(define-public openjpeg-data
(package
(name "openjpeg-data")
- (version "2020.11.30")
+ (version "2021.09.26")
(source
(origin
(method git-fetch)
(uri
(git-reference
(url "https://github.com/uclouvain/openjpeg-data")
- (commit "cd724fb1f93e6af41ebc68c4904f4bf2a4cd1e60")))
+ (commit "1f3d093030f9a0b43353ec6b48500f65786ff57a")))
(file-name (git-file-name name version))
(sha256
- (base32 "1q2swh4g9r9haqs075fyk42aclqcs9q51lqqzfb57lisszminpwm"))))
+ (base32 "13jpdaqk7mngk0xw6xbh9zgipip6n25spvqd97hwpfna1zyh8lzh"))))
(build-system copy-build-system)
(synopsis "Test files for OpenJPEG")
(description "OpenJPEG-Data contains all files required to run the openjpeg
@@ -799,7 +786,7 @@ test suite, including conformance tests (following Rec. ITU-T T.803 | ISO/IEC
(define-public openjpeg
(package
(name "openjpeg")
- (version "2.4.0")
+ (version "2.5.0")
(source
(origin
(method git-fetch)
@@ -808,7 +795,7 @@ test suite, including conformance tests (following Rec. ITU-T T.803 | ISO/IEC
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "143dvy5g6v6129lzvl0r8mrgva2fppkn0zl099qmi9yi9l9h7yyf"))))
+ (base32 "0xvcxlzqlylnjsyl1j64d7rgzv68ihm4qy6fpdrix3xzbqb3fjpz"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -974,7 +961,7 @@ Metafile}, and @acronym{EMF+, Enhanced Metafile Plus} files.")
(define-public imlib2
(package
(name "imlib2")
- (version "1.9.1")
+ (version "1.10.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -982,7 +969,7 @@ Metafile}, and @acronym{EMF+, Enhanced Metafile Plus} files.")
"/imlib2-" version ".tar.xz"))
(sha256
(base32
- "0hsdfs7wa5f7fwb5nfgqzvf29bp59rgy0i0c4m6mvgpzpww408ja"))))
+ "1fnbh6vj0d9l1c2bzw9psxh3wnlbr1nlfzi16w60hp48gj9ilz3j"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list "--disable-static")))
@@ -1091,7 +1078,8 @@ supplies a generic doubly-linked list and some string functions.")
"LibJXR" "LibWebP" "OpenEXR" "ZLib"))))
(patches
(append
- (search-patches "freeimage-unbundle.patch")
+ (search-patches "freeimage-unbundle.patch"
+ "freeimage-libtiff-compat.patch")
;; Take one patch from Arch Linux that adds LibRaw 0.20 compatibility.
(list (origin
(method url-fetch)
@@ -1651,49 +1639,44 @@ is hereby granted."))))
(define-public libjpeg-turbo
(package
(name "libjpeg-turbo")
- (version "2.0.5")
+ (version "2.1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libjpeg-turbo/"
version "/libjpeg-turbo-" version ".tar.gz"))
(sha256
(base32
- "0pbv6pc97kbj7ib31qcwi7lnmm9xg5y3b11aasmkhfjvf7rgdy0n"))))
+ "0arl61ici38ann5xjidwdzkhmjdp1r95x4x4zinnh4qs2fhjdvfk"))))
(build-system cmake-build-system)
(native-inputs
(list nasm))
(arguments
- `(#:configure-flags '("-DCMAKE_INSTALL_LIBDIR:PATH=lib"
- "-DENABLE_STATIC=0"
- ;; djpeg-shared-3x2-float-prog-cmp fails on 32-bit PPC.
- ,@(if (string=? "powerpc-linux" (%current-system))
- `("-DFLOATTEST=NO")
- '())
- ;; The build system probes for the current CPU, but
- ;; that fails when cross-compiling.
- ,@(let ((target (%current-target-system)))
- (if target
- (cond
- ((string-prefix? "arm" target)
- `("-DCMAKE_SYSTEM_PROCESSOR=arm"))
- ((string-prefix? "aarch64" target)
- `("-DCMAKE_SYSTEM_PROCESSOR=aarch64"))
- ((string-prefix? "i686" target)
- `("-DCMAKE_SYSTEM_PROCESSOR=x86"))
- ((string-prefix? "x86_64" target)
- `("-DCMAKE_SYSTEM_PROCESSOR=x86_64"))
- ;; 32-bit and 64-bit
- ((string-prefix? "powerpc" target)
- `("-DCMAKE_SYSTEM_PROCESSOR=powerpc"))
- ((string-prefix? "riscv64" target)
- `("-DCMAKE_SYSTEM_PROCESSOR=riscv64"))
- (else '()))
- '())))
- ,@(if (%current-target-system)
- '()
- ;; Use a special "bootstrap" CMake for the native build to work
- ;; around a circular dependency between CMake and this package.
- `(#:cmake ,cmake-bootstrap))))
+ (list #:configure-flags
+ #~'("-DCMAKE_INSTALL_LIBDIR:PATH=lib"
+ "-DENABLE_STATIC=0"
+ ;; djpeg-shared-3x2-float-prog-cmp fails on 32-bit PPC.
+ #$@(if (string=? "powerpc-linux" (%current-system))
+ '("-DFLOATTEST=NO")
+ '())
+ ;; The build system probes for the current CPU, but
+ ;; that fails when cross-compiling.
+ #$@(let ((target (%current-target-system)))
+ (if target
+ (cond ((string-prefix? "arm" target)
+ '("-DCMAKE_SYSTEM_PROCESSOR=arm"))
+ ((string-prefix? "aarch64" target)
+ '("-DCMAKE_SYSTEM_PROCESSOR=aarch64"))
+ ((string-prefix? "i686" target)
+ '("-DCMAKE_SYSTEM_PROCESSOR=x86"))
+ ((string-prefix? "x86_64" target)
+ '("-DCMAKE_SYSTEM_PROCESSOR=x86_64"))
+ ;; 32-bit and 64-bit
+ ((string-prefix? "powerpc" target)
+ '("-DCMAKE_SYSTEM_PROCESSOR=powerpc"))
+ ((string-prefix? "riscv64" target)
+ '("-DCMAKE_SYSTEM_PROCESSOR=riscv64"))
+ (else '()))
+ '())))))
(home-page "https://libjpeg-turbo.org/")
(synopsis "SIMD-accelerated JPEG image handling library")
(description "libjpeg-turbo is a JPEG image codec that accelerates baseline