aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm75
1 files changed, 64 insertions, 11 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 77a0c09b4c..d467096708 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -6,6 +6,8 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +26,7 @@
(define-module (gnu packages icu4c)
#:use-module (gnu packages)
+ #:use-module (gnu packages java)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (guix licenses)
@@ -93,6 +96,22 @@ C/C++ part.")
(license x11)
(home-page "http://site.icu-project.org/")))
+(define-public icu4c-67
+ (package
+ (inherit icu4c)
+ (version "67.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/unicode-org/icu/releases/download/release-"
+ (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
+ "/icu4c-"
+ (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
+ "-src.tgz"))
+ (sha256
+ (base32
+ "1p6mhvxl0xr2n0g6xdps3mwzwlv6mjsz3xlpm793p9aiybb0ra4l"))))))
+
(define-public icu4c-build-root
(package
(inherit icu4c)
@@ -115,22 +134,56 @@ C/C++ part.")
(define-public java-icu4j
(package
(name "java-icu4j")
- (version "59.1")
+ (version "66.1")
(source (origin
(method url-fetch)
- (uri (string-append "http://download.icu-project.org/files/icu4j/"
- version "/icu4j-"
- (string-map (lambda (x)
- (if (char=? x #\.) #\_ x))
- version)
- "-src.jar"))
+ (uri (string-append
+ "https://github.com/unicode-org/icu/releases/download/release-"
+ (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
+ "/icu4j-"
+ (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
+ ".tgz"))
(sha256
- (base32
- "0bgxsvgi0qcwj60pvcxrf7a3fbk7aksyxnfwpbzavyfrfzixqh0c"))))
+ (base32 "1ahdyz9209lwl7knb2l3gmnkkby221p0vpgx70fj4j02rdzgvw0d"))))
(build-system ant-build-system)
(arguments
- `(#:tests? #f ; no tests included
- #:jar-name "icu4j.jar"))
+ `(#:make-flags
+ (list (string-append "-Djunit.core.jar="
+ (car (find-files
+ (assoc-ref %build-inputs "java-junit")
+ ".*.jar$")))
+ (string-append "-Djunit.junitparams.jar="
+ (car (find-files
+ (assoc-ref %build-inputs "java-junitparams")
+ ".*.jar$")))
+ (string-append "-Djunit.hamcrest.jar="
+ (car (find-files
+ (assoc-ref %build-inputs "java-hamcrest-core")
+ ".*.jar$"))))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "..")
+ #t))
+ (add-before 'build 'remove-ivy
+ (lambda _
+ ;; This target wants to download ivy and use it to download
+ ;; junit.
+ (substitute* "build.xml"
+ (("depends=\"test-init-junit-dependency\"") ""))
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((share (string-append (assoc-ref outputs "out")
+ "/share/java/")))
+ (mkdir-p share)
+ (install-file "icu4j.jar" share)
+ #t))))))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-junitparams" ,java-junitparams)
+ ("java-hamcrest-core" ,java-hamcrest-core)))
(home-page "http://site.icu-project.org/")
(synopsis "International Components for Unicode")
(description
* gnu/services.scm (files->etc-directory)[assert-no-duplicates]: New procedure. Use it. Ludovic Courtès 2020-04-05services: Allow modprobe to use "/etc/modprobe.d"....* gnu/services.scm (%modprobe-wrapper): Set 'MODPROBE_OPTIONS' environment variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Brice Waegeneire 2020-04-02services: Accumulate builds for 'system' entries....That way, more build requests are accumulated when running "guix system build". * gnu/services.scm (system-derivation): Use 'mapm/accumulate-builds' rather than 'sequence'. Ludovic Courtès 2019-12-07services: Add 'provenance-service-type'....* gnu/services.scm (object->pretty-string) (channel->code, channel->sexp, provenance-file) (provenance-entry): New procedures. (provenance-service-type): New variable. * gnu/system.scm (operating-system-with-provenance): New procedure. * doc/guix.texi (Service Reference): Document 'provenance-service-type'. Ludovic Courtès 2019-11-09services: 'fold-services' memoizes service values....Previously 'fold-services' could end up traversing the same services in the graph several times, which is what this change addresses. The hit rate on the 'add-data-to-store' cache goves from 9% to 8% on "guix system build desktop.tmpl -nd", and the number of lookups in that cache goes from 4458 to 4383. * gnu/services.scm (fold-services): Turn 'loop' into a monadic procedure in %STATE-MONAD and use it to memoize values of visited services. Ludovic Courtès 2019-08-14remote: Remove '--system' argument....* gnu/services.scm (activation-script): Return a <program-file> rather than a <scheme-file>. * gnu/deploy.scm (guix-deploy): Remove handling for '--system'. (show-help): Remove documentation for '--system'. (%default-options): Remove default setting for 'system'. Jakob L. Kreuze 2019-05-10services: 'gc-root-service-type' now has a default value....* gnu/services.scm (gc-root-service-type)[default-value]: New field. Ludovic Courtès