aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 0 insertions, 7 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 04c69a8dca..183d0eb4cb 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -140,13 +140,6 @@
(copy-file (assoc-ref inputs "ghc-testsuite")
"ghc-testsuite.tar.xz")
(system* "tar" "xvf" "ghc-testsuite.tar.xz"))
- ;; We need to install an UTF-8 locale for the tests to produce results
- ;; identical to the expected ones.
- (system* "localedef" "--no-archive"
- "--prefix" (getcwd) "-i" "en_US"
- "-f" "UTF-8" "./en_US.UTF-8")
- (setenv "LOCPATH" (getcwd))
- (setenv "LC_ALL" "en_US.UTF-8")
(substitute*
(list "testsuite/timeout/Makefile"
"testsuite/timeout/timeout.py"