aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index e1514fb40b..0652e2933d 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -1089,11 +1089,17 @@ technology, such as head mounted displays with built in head tracking.")
(("dependencies/json")
(string-append #$(this-package-input "nlohmann-json")
"/include/nlohmann")))))
+ (add-after 'unpack 'patch-chmod
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "scripts/build-udev-rules.sh"
+ (("/bin/chmod") (string-append (assoc-ref inputs "coreutils")
+ "/bin/chmod")))))
;; Call qmake instead of configure to create a Makefile.
(replace 'configure
(lambda _ (invoke "qmake" "PREFIX=/" "OpenRGB.pro"))))))
(inputs
- (list hidapi
+ (list coreutils
+ hidapi
hueplusplus
nlohmann-json
libusb