aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5402adf0fa..7dd5d93097 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6905,30 +6905,6 @@ the External Data Representation (XDR) standard protocol as specified in RFC
4506 (obsoletes RFC 1832 and RFC 1014) in pure Go.")
(license license:isc)))
-(define-public go-github-com-dustin-go-humanize
- (package
- (name "go-github-com-dustin-go-humanize")
- (version "1.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dustin/go-humanize")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1iyhd90pnmxh64nhsh6k02c1b1glpmhh4whga9jgb9g0i5hz3sya"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/dustin/go-humanize"))
- (home-page "https://github.com/dustin/go-humanize")
- (synopsis "Humane unit formatter")
- (description "@code{go-humanize} provides formatters for units to human
-friendly sizes. It converts boring ugly numbers to human-friendly strings and
-back.")
- (license license:expat)))
-
(define-public go-gopkg-in-djherbis-times-v1
(package
(name "go-gopkg-in-djherbis-times-v1")
r>2024-01-19gnu: darktable: Enable more optional features....* gnu/packages/photo.scm (darktable)[inputs]: Add libjxl, portmidi. Change-Id: I7747dfc2e88379a13182590f87514951bdd70e0c Vinicius Monego 2024-01-19gnu: darktable: Build with GCC....* gnu/packages/photo.scm (darktable)[arguments][#:phases]: Delete the 'prepare-build-environment phase. [native-inputs]: Remove clang. Add gcc-13. Change-Id: Ia0dc1c6a717ccd00cd31d378aa51ce63fbf1806a Vinicius Monego 2024-01-17gnu: perl-image-exiftool: Update to 12.70....* gnu/packages/photo.scm (perl-image-exiftool): Update to 12.70. Change-Id: If8e26b7e92cb530391cdd1dd12e78b371494a6b3 kiasoc5 2023-09-17gnu: enblend-enfuse: Build documentation....Notes: * transfig is not needed according to the NEWS since 4.2. * help2man is not optional. * gnu/packages/photo.scm (enblend-enfuse)[native-inputs]: Remove libxml2, tidy-html and transfig. Replace imagemagick with imagemagick/stable. Add graphviz-minimal, font-ghostscript, librsvg, m4, perl-readonly, texlive-texloganalyser, texlive-bold-extra, texlive-cm-mf-extra-bold, texlive-comment, texlive-float, texlive-enumitem, texlive-mdwtools, texlive-hyphenat, texlive-index, texlive-listings, texlive-microtype, texlive-etoolbox, texlive-nag, texlive-ragged2e, texlive-shorttoc, texlive-bigfoot, texlive-xstring and hevea. [arguments]<#:phases>: Add 'fontconfig-cache, 'exclude-doc-from-check and 'install-doc. Replace 'build and 'install. [outputs]: Add 'doc. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2023-09-17gnu: enblend-enfuse: Backport upstream fixes....Backport changes for reproducible builds & missing include. * gnu/packages/patches/enblend-enfuse-reproducible.patch: New file. * gnu/local.mk: Register it. * gnu/packages/photo.scm (enblend-enfuse)[source]: Use newly added patch. Add snippet to fix missing header. [arguments]<#:phases>: Remove 'add-missing-include. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Bruno Victal 2023-08-21gnu: darktable: Enable building on riscv64-linux....* gnu/packages/photo.scm (darktable)[supported-systems]: Add riscv64-linux. Efraim Flashner