aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm39
1 files changed, 0 insertions, 39 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6cf873d79d..55cff297cf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5544,45 +5544,6 @@ and from termios translations, readCh, reading passwords, etc.")
into URL query parameters.")
(license license:bsd-3))))
-(define-public go-github-com-google-renameio
- (package
- (name "go-github-com-google-renameio")
- (version "1.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/renameio")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qn84nra9nxqyqg4i496b6ijbhnxvx66hdndwl7qh7r6q8lz2ba5"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/google/renameio"))
- (home-page "https://github.com/google/renameio/")
- (synopsis "Atomically create or replace a file or symbolic link")
- (description "@code{renameio} Go package provides a way to atomically
-create or replace a file or symbolic link.")
- (license license:asl2.0)))
-
-(define-public go-github-com-google-renameio-v2
- (package/inherit go-github-com-google-renameio
- (name "go-github-com-google-renameio-v2")
- (version "2.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/renameio")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "13vc7p43zz5pmgli4k18b15khxpca1zd8v1ga0ryq7ddyz55fg7i"))))
- (arguments
- (list
- #:import-path "github.com/google/renameio/v2"))))
-
(define (go-gotest-tools-source version sha256-base32-hash)
(origin
(method git-fetch)