aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-check.scm')
-rw-r--r--gnu/packages/golang-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 130daae28a..53bcc303bf 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -998,6 +998,33 @@ strings must or must not be sent to a given local UDP listener.")
such as readers and writers that fail after N consecutive reads/writes.")
(license license:expat)))
+(define-public go-github-com-tj-assert
+ (package
+ (name "go-github-com-tj-assert")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tj/assert")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j5swk3fjq1h5fpqkipddz2ccnbidr7qrpm5dpdaflg9q5jnc673"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/tj/assert"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/tj/assert")
+ (synopsis "Golang @code{testify/assert} but as @code{testify/require}")
+ (description
+ "Package assert implements the same assertions as the
+@url{https://github.com/stretchr/testify, assert} package but stops test
+execution when a test fails.")
+ (license license:expat)))
+
(define-public go-github.com-smartystreets-assertions
(package
(name "go-github.com-smartystreets-assertions")