aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm41
1 files changed, 13 insertions, 28 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 34f5078581..abb4066417 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3043,7 +3043,7 @@ configuring CUPS.")
#t)))))
(propagated-inputs
`(;; In Requires of libnotify.pc.
- ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("glib" ,glib)))
(inputs
`(("gtk+" ,gtk+)
@@ -3224,7 +3224,6 @@ the GNOME desktop environment.")
(sha256
(base32
"1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))))
- (replacement libcroco/fixed)
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -3243,21 +3242,6 @@ XML/CSS rendering engine.")
;; LGPLv2.1-only.
(license license:lgpl2.1)))
-(define libcroco/fixed
- (package
- (inherit libcroco)
- (name "libcroco")
- (version "0.6.13")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1m110rbj5d2raxcdp4iz0qp172284945awrsbdlq99ksmqsc4zkn"))
- (patches (search-patches "libcroco-CVE-2020-12825.patch"))))))
-
(define-public libgsf
(package
(name "libgsf")
@@ -3281,11 +3265,11 @@ XML/CSS rendering engine.")
("perl" ,perl)
("perl-xml-parser" ,perl-xml-parser)))
(inputs
- `(("zlib" ,zlib)
+ `(("gdk-pixbuf" ,gdk-pixbuf)
+ ("zlib" ,zlib)
("bzip2" ,bzip2)))
(propagated-inputs
- `(("gdk-pixbuf" ,gdk-pixbuf)
- ("glib" ,glib)
+ `(("glib" ,glib)
("libxml2" ,libxml2)))
(home-page "https://www.gnome.org/projects/libgsf")
(synopsis "GNOME's Structured File Library")
@@ -3309,6 +3293,7 @@ dealing with different structured file formats.")
(base32
"1fljkag2gr7c4k5mn798lgf9903xslz8h51bgvl89nnay42qjqpp"))))
(build-system gnu-build-system)
+ (outputs '("out" "debug"))
(arguments
`(#:configure-flags
(list "--disable-static"
@@ -3351,11 +3336,11 @@ dealing with different structured file formats.")
("libcroco" ,libcroco)
("bzip2" ,bzip2)
("libgsf" ,libgsf)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("libxml2" ,libxml2)))
(propagated-inputs
;; librsvg-2.0.pc refers to all of that.
`(("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)))
(home-page "https://wiki.gnome.org/LibRsvg")
(synopsis "Render SVG files using Cairo")
@@ -3366,7 +3351,7 @@ library.")
(define-public librsvg-next
(package
- (name "librsvg")
+ (name "librsvg-next")
(version "2.50.3")
(source (origin
(method url-fetch)
@@ -3381,7 +3366,7 @@ library.")
'(begin (delete-file-recursively "vendor")
#t))))
(build-system cargo-build-system)
- (outputs '("out" "doc"))
+ (outputs '("out" "debug" "doc"))
(arguments
`(#:install-source? #f
#:modules
@@ -3530,6 +3515,7 @@ library.")
`(("bzip2" ,bzip2)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
+ ("gdk-pixbuf" ,gdk-pixbuf)
("harfbuzz" ,harfbuzz)
("libcroco" ,libcroco)
("libgsf" ,libgsf)
@@ -3537,7 +3523,6 @@ library.")
("pango" ,pango)))
(propagated-inputs
`(("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf)
("glib" ,glib)))
(synopsis "SVG rendering library")
(description "Librsvg is a library to render SVG images to Cairo surfaces.
@@ -5491,7 +5476,7 @@ service via the system message bus.")
;; gweather-3.0.pc refers to GTK+, GDK-Pixbuf, GLib/GObject, libxml, and
;; libsoup.
`(("gtk+" ,gtk+)
- ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("libxml2" ,libxml2)
("libsoup" ,libsoup)
("geocode-glib" ,geocode-glib)))
@@ -5756,7 +5741,7 @@ throughout GNOME for API documentation).")
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("glib" ,glib)
- ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("libx11" ,libx11)
("libxext" ,libxext)
("libxfixes" ,libxfixes)
@@ -7440,7 +7425,7 @@ to display dialog boxes from the commandline and shell scripts.")
;; mutter-clutter-1.0.pc and mutter-cogl-1.0.pc refer to these:
("atk" ,atk)
("cairo" ,cairo)
- ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("glib" ,glib)
("json-glib" ,json-glib)
("libinput" ,libinput)
@@ -10475,7 +10460,7 @@ photo-booth-like software, such as Cheese.")
("clutter-gst" ,clutter-gst)
("clutter-gtk" ,clutter-gtk)
("libcanberra" ,libcanberra)
- ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gdk-pixbuf" ,gdk-pixbuf+svg)
("glib" ,glib)
("gstreamer" ,gstreamer)))
(inputs