aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b4016a2fbc..e020632078 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -799,15 +799,7 @@ patterns.")
(add-after 'unpack 'unpack-libgd
(lambda _
(copy-recursively
- #$(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.gnome.org/GNOME/libgd")
- (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
- (file-name (git-file-name "libgd" version))
- (sha256
- (base32
- "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs")))
+ #$(this-package-native-input "libgd-checkout")
"subprojects/libgd"))))))
(inputs (list glib
gnome-autoar
@@ -821,6 +813,15 @@ patterns.")
(native-inputs (list desktop-file-utils ;for update-desktop-database
gettext-minimal
`(,glib "bin")
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/libgd")
+ (commit "c7c7ff4e05d3fe82854219091cf116cce6b19de0")))
+ (file-name "libgd-checkout")
+ (sha256
+ (base32
+ "16yld0ap7qj1n96h4f2sqkjmibg7xx5xwkqxdfzam2nmyfdlrrrs")))
itstool
pkg-config
python))