aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 2da57ee8ee..a0490e5421 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -185,8 +185,7 @@ of a larger interface.")
"1w68h81kqkqnziixrx21qs0gfv2z79651h19sxn226xdb58mjgqb"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.55
- #:configure-flags
+ `(#:configure-flags
(list "-Denable-gir=false")))
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -225,8 +224,7 @@ provided, as well as a framework to add new color models and data types.")
"1pd8xkx70k0fsi1hrzrmaify7112wjmxzk0p6bi6js89yhn7h4n1"))))
(build-system meson-build-system)
(arguments
- `(#:meson ,meson-0.55
- #:configure-flags
+ `(#:configure-flags
(list "-Dintrospection=false")
#:phases
(modify-phases %standard-phases
@@ -304,7 +302,7 @@ buffers.")
;; Install 'sitecustomize.py' into gimp's python directory to
;; add pygobject and pygtk to pygimp's search path.
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((pythonpath (getenv "PYTHONPATH"))
+ (let* ((pythonpath (getenv "GUIX_PYTHONPATH"))
(out (assoc-ref outputs "out"))
(sitecustomize.py
(string-append
@@ -608,7 +606,7 @@ transferring the style of an image.")
;; Install 'sitecustomize.py' into glimpse's python directory to
;; add pygobject and pygtk to pygimp's search path.
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((pythonpath (getenv "PYTHONPATH"))
+ (let* ((pythonpath (getenv "GUIX_PYTHONPATH"))
(out (assoc-ref outputs "out"))
(sitecustomize.py
(string-append
x/commit/gnu/packages/crypto.scm?id=6f4ceb544952ceb1c34fcd754547003b7dd0c16f'>gnu: libscrypt: Use G-expressions....* gnu/packages/crypto.scm (libscrypt)[arguments]: Rewrite as G-expressions. Tobias Geerinckx-Rice 2022-05-08gnu: libscrypt: Update to 1.22....* gnu/packages/crypto.scm (libscrypt): Update to 1.22. Tobias Geerinckx-Rice 2022-05-06gnu: Add rust-blake3-1....* gnu/packages/crypto.scm (rust-blake3-1): New variable. Ricardo Wurmus 2022-03-18gnu: b2sum: Produce generic binaries and enable tuning....* gnu/packages/crypto.scm (b2sum)[arguments]: Add 'de-tune' phase. [properties]: Mark the package as tunable. Leo Famulari 2022-03-16gnu: cryfs: Update to 0.11.2....* gnu/packages/crypto.scm (cryfs): Update to 0.11.2. [arguments]: Fix build with boost 1.77 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Brendan Tildesley 2022-03-14gnu: crypto++: Update to 8.6.0....* gnu/packages/crypto.scm (crypto++): Update to 8.6.0. Note: This release includes a fix for a bug where code using AVX2 instructions produced incorrect encrypted files: https://github.com/weidai11/cryptopp/issues/1069 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Brendan Tildesley 2022-03-11gnu: Add libxcrypt....* gnu/packages/crypto.scm (libxcrypt): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Allan Adair