about
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index cd144772b8..5fc3159136 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1204,17 +1204,17 @@ provides the GNU compiler for the Go programming language."))
(define-public isl
(package
(name "isl")
- (version "0.23")
+ (version "0.24")
(source (origin
(method url-fetch)
;; Used to be at isl.gforge.inria.fr.
(uri (list (string-append "mirror://sourceforge/libisl/isl-"
- version ".tar.bz2")
+ version ".tar.xz")
(string-append %gcc-infrastructure
- "isl-" version ".tar.bz2")))
+ "isl-" version ".tar.xz")))
(sha256
(base32
- "0k91zck10zxs9sk3yrbb92y1j3w981w3fbwkfwd7kl779b0j52f5"))))
+ "1bgbk6n93qqn7w8v21kxf4x6dc3z0ypqrzvgfd46nhagak60ac84"))))
(build-system gnu-build-system)
(outputs '("out" "static"))
(arguments
license:) #:use-module (guix packages)) (define-public rrdtool (package (name "rrdtool") (version "1.8.0") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/oetiker/rrdtool-1.x") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "04dhygsp34dykrnbbcqni5f7hih0hzqbnj6d2sl439lqbx9k3q3b")))) (build-system gnu-build-system) (inputs (list cairo freetype glib gtk+-2 libxml2 pango python)) (native-inputs (list groff pkg-config ;; For tests. bc perl ; will also build Perl bindings tzdata-for-tests)) (arguments (list #:disallowed-references (list (gexp-input tzdata-for-tests)) #:phases #~(modify-phases %standard-phases (add-before 'check 'prepare-test-environment (lambda* (#:key inputs #:allow-other-keys) (setenv "TZDIR" (search-input-directory inputs "share/zoneinfo")))) (add-after 'install 'remove-native-input-references (lambda _ (let ((examples (string-append #$output "/share/rrdtool/examples"))) ;; Drop shebangs from examples to avoid depending on native-input ;; perl. It's clear from context and extension how to run them. (substitute* (find-files examples "\\.pl$") (("^#!.*") "")))))))) (home-page "https://oss.oetiker.ch/rrdtool/") (synopsis "Time-series data storage and display system") (description "The Round Robin Database Tool (RRDtool) is a system to store and display time-series data (e.g. network bandwidth, machine-room temperature, server load average). It stores the data in Round Robin Databases (RRDs), a very compact way that will not expand over time. RRDtool processes the extracted data to enforce a certain data density, allowing for useful graphical representation of data values.") (license license:gpl2+))) ; with license exception that allows combining ; with many other licenses.