aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 20b8916765..9274fc494d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7676,23 +7676,21 @@ abilities and powers.")
(sha256
(base32 "0hr58w1d2yw82vm9lkln05z6d4sjlcr6grxhf6sqdqwyfy9nv1mw"))))
(arguments
- `(#:tests? #f
- #:make-flags '("CC=gcc"
- "MP3LIB=mpg123"
- "USE_CODEC_FLAC=1"
- "USE_CODEC_MIKMOD=1"
- "USE_SDL2=1"
- "-CQuake")
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'fix-makefile-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/bin"))
- (substitute* "Quake/Makefile"
- (("/usr/local/games")
- (string-append out "/bin")))
- #t))))))
+ (list #:tests? #f
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "MP3LIB=mpg123"
+ "USE_CODEC_FLAC=1"
+ "USE_CODEC_MIKMOD=1"
+ "USE_SDL2=1"
+ "-CQuake")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-makefile-paths
+ (lambda _
+ (mkdir-p (string-append #$output "/bin"))
+ (substitute* "Quake/Makefile"
+ (("/usr/local/games")
+ (string-append #$output "/bin"))))))))
(build-system gnu-build-system)
(inputs (list libmikmod
libvorbis