aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm49
1 files changed, 21 insertions, 28 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 08f3c3f56f..9ba53cd044 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -29,8 +29,9 @@
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2021, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
-;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 muradm <mail@muradm.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -730,6 +731,13 @@ the freedesktop.org XDG Base Directory specification.")
(substitute* "meson.build"
(("join_paths\\(bindir, 'pkttyagent'\\)")
"'\"/run/current-system/profile/bin/pkttyagent\"'"))))
+ (add-after 'unpack 'use-global-hook-directory
+ ;; XXX There is no run-time setting to set this per-process, only a
+ ;; build-time, hard-coded list of global directories.
+ (lambda _
+ (substitute* (list "src/login/elogind-dbus.c"
+ "src/sleep/sleep.c")
+ (("PKGSYSCONFDIR") "\"/etc/elogind\""))))
(add-after 'unpack 'adjust-tests
(lambda _
;; Skip the following test, which depends on users such as 'root'
@@ -1175,14 +1183,15 @@ Python.")
(define-public wayland
(package
(name "wayland")
- (version "1.20.0")
+ (version "1.21.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://wayland.freedesktop.org/releases/"
+ (uri (string-append "https://gitlab.freedesktop.org/" name
+ "/" name "/-/releases/" version "/downloads/"
name "-" version ".tar.xz"))
(sha256
(base32
- "09c7rpbwavjg4y16mrfa57gk5ix6rnzpvlnv1wp7fnbh9hak985q"))))
+ "1b0ixya9bfw5c9jx8mzlr7yqnlyvd3jv5z8wln9scdv8q5zlvikd"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -1240,15 +1249,15 @@ fullscreen) or other display servers.")
(define-public wayland-protocols
(package
(name "wayland-protocols")
- (version "1.23")
+ (version "1.29")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://wayland.freedesktop.org/releases/"
- "wayland-protocols-" version ".tar.xz"))
+ (uri (string-append "https://gitlab.freedesktop.org/wayland/"
+ name "/-/releases/" version "/downloads/"
+ name "-" version ".tar.xz"))
(sha256
(base32
- "0xizccackgwszjhlq7jjiv2z2gwppljx0w32ga91bxlnby8z22kc"))))
+ "1n4yzyjbp5fng8pvckandymvwc47mkwyi4pyvr6p0dn7bavrlpp2"))))
(build-system meson-build-system)
(inputs
(list wayland))
@@ -1268,20 +1277,6 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
. "https://wayland.freedesktop.org/releases.html")))
(license license:expat)))
-(define-public wayland-protocols-next
- (package
- (inherit wayland-protocols)
- (name "wayland-protocols")
- (version "1.26")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://wayland.freedesktop.org/releases/"
- "wayland-protocols-" version ".tar.xz"))
- (sha256
- (base32
- "04vgllmpmrv14x3x64ns01vgwx4hriljayjkz9idgbv83i63hly5"))))))
-
(define-public wayland-utils
(package
(name "wayland-utils")
@@ -1297,7 +1292,7 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
"04k1yhyh7h4xawbhpz9pf6cpfmmp1l862fdgsvvnyp4hg9n3j9aj"))))
(build-system meson-build-system)
(native-inputs (list pkg-config))
- (inputs (list libdrm wayland wayland-protocols-next))
+ (inputs (list libdrm wayland wayland-protocols))
(home-page "https://wayland.freedesktop.org/")
(synopsis "Display information about the Wayland protocols")
(description "This package provides @code{wayland-info} tool that can be
@@ -1374,7 +1369,7 @@ compositor.")
linux-pam
pango
pipewire
- wayland-protocols-next
+ wayland-protocols
xorg-server-xwayland))
(propagated-inputs
(list libxkbcommon pixman wayland))
@@ -1956,9 +1951,7 @@ share connections to real-time communication services without conflicting.")
pkg-config
vala))
(inputs
- ;; TODO: remove pango-next after it's the default.
- (list gtk+
- pango-next))
+ (list gtk+))
(propagated-inputs
;; colord-gtk.pc refers to all these.
(list colord gtk))