aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm43
1 files changed, 26 insertions, 17 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 5638560b9e..341554b687 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2020, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2020, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Nikita <nikita@n0.is>
@@ -85,19 +85,28 @@
(define-public freetype
(package
(name "freetype")
- (version "2.10.4")
+ (version "2.13.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
version ".tar.xz"))
(sha256
- (base32 "112pyy215chg7f7fmp2l9374chhhpihbh8wgpj5nj6avj3c59a46"))))
+ (base32 "0k32jaaz4pfhw34xwr6a38fncrpwr9fn5ij35m5w4dkn0jykmqjy"))))
(build-system gnu-build-system)
(arguments
;; The use of "freetype-config" is deprecated, but other packages still
;; depend on it.
- `(#:configure-flags (list "--enable-freetype-config")))
+ `(#:configure-flags (list "--enable-freetype-config")
+ #:disallowed-references (,pkg-config)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'remove-reference-to-pkg-config
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/bin/freetype-config")
+ (((search-input-file inputs "/bin/pkg-config"))
+ "pkg-config"))))))))
(native-inputs
(list pkg-config))
(propagated-inputs
@@ -112,7 +121,7 @@ It supports both bitmap and scalable formats, including TrueType, OpenType,
Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others. It supports high-speed
anti-aliased glyph bitmap generation with 256 gray levels.")
(license license:freetype) ; some files have other licenses
- (home-page "https://www.freetype.org/")))
+ (home-page "https://freetype.org/")))
(define-public opentype-sanitizer
(package
@@ -265,7 +274,7 @@ them as it goes.")
python-booleanoperations
python-defcon
python-fontmath
- python-fonttools-next
+ python-fonttools
python-lxml
python-tqdm
python-ufonormalizer
@@ -467,7 +476,7 @@ converts any cubic curves to quadratic. The most useful function is probably
python-compreffor
python-cu2qu
python-defcon
- python-fonttools-next
+ python-fonttools
python-skia-pathops
python-ufolib2))
(home-page "https://github.com/googlefonts/ufo2ft")
@@ -613,7 +622,7 @@ process. FontParts is the successor of RoboFab.")
python-xmldiff))
(propagated-inputs
(list python-defcon
- python-fonttools-next
+ python-fonttools
python-openstep-plist
python-ufolib2
python-ufo2ft
@@ -771,7 +780,7 @@ suite of the @code{psautohint} package.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "-vv")))))))
- (propagated-inputs (list python-fonttools-next))
+ (propagated-inputs (list python-fonttools))
(native-inputs
(list psautohint-font-data
python-fs
@@ -1134,14 +1143,14 @@ Font Format (WOFF).")
(hidden-package
(package
(name "fontconfig-minimal")
- (version "2.13.94")
+ (version "2.14.0")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.freedesktop.org/software/"
"fontconfig/release/fontconfig-" version ".tar.xz"))
(sha256 (base32
- "0g004r0bkkqz00mpm3svnnxn7d83158q0yb9ggxryizxfg5m5w55"))
+ "1b4v1r94ri44p4a3kbwd38ig5jgdgcfgwdfm6fqzvfvlki6bignw"))
(patches (search-patches "fontconfig-cache-ignore-mtime.patch"))))
(build-system gnu-build-system)
;; In Requires or Requires.private of fontconfig.pc.
@@ -1454,14 +1463,14 @@ definitions.")
(define-public fontforge
(package
(name "fontforge")
- (version "20201107")
+ (version "20220308")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/fontforge/fontforge/releases/download/"
version "/fontforge-" version ".tar.xz"))
(sha256
- (base32 "0y3c8x1i6yf6ak9m5dhr1nldgfmg7zhnwdfd57ffs698c27vmg38"))))
+ (base32 "0ncfc4ajwy4ng6b6h79w52jh9z3lngvf3f3ldi1wzkhcg9zh3r01"))))
(build-system cmake-build-system)
(native-inputs
(list pkg-config))
@@ -1479,7 +1488,6 @@ definitions.")
("libspiro" ,libspiro)
("libtiff" ,libtiff)
("libungif" ,libungif)
- ("libuninameslist" ,libuninameslist)
("libxft" ,libxft)
("libxml2" ,libxml2)
("pango" ,pango)
@@ -1548,8 +1556,9 @@ generate bitmaps.")
`(modify-phases ,phases
(delete 'do-not-override-RPATH)))))
(inputs
- `(("python" ,python-2)
- ,@(alist-delete "python" (package-inputs fontforge))))))
+ (modify-inputs (package-inputs fontforge)
+ (prepend libuninameslist)
+ (replace "python" python-2)))))
(define-public python-statmake
(package
@@ -1593,7 +1602,7 @@ generate bitmaps.")
(propagated-inputs
(list python-attrs
python-cattrs
- python-fonttools-next))
+ python-fonttools))
(home-page "https://github.com/daltonmaag/statmake")
(synopsis "Apply OpenType STAT information to a variable font")
(description