path: root/gnu/packages/fontutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fontutils.scm')
-rw-r--r--gnu/packages/fontutils.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index cacda2ed04..1d9c81b8a6 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +55,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -456,7 +457,7 @@ primary means by which end users perform conversions, and they have not
been designed, tested, and debugged to the extent that general-purpose
applications should be.")
(license license:lgpl2.1+)
- (home-page "http://scripts.sil.org/cms/scripts/page.php?cat_id=teckit")))
+ (home-page "https://scripts.sil.org/cms/scripts/page.php?cat_id=teckit")))
(define-public graphite2
(package
@@ -843,7 +844,7 @@ generated list of fallback fonts are checked.")
(define-public fontmanager
(package
(name "fontmanager")
- (version "0.7.7")
+ (version "0.8.4")
(source
(origin
(method git-fetch)
@@ -853,7 +854,7 @@ generated list of fallback fonts are checked.")
(file-name (git-file-name name version))
(sha256
(base32
- "1bzqvspplp1zj0n0869jqbc60wgbjhf0vdrn5bj8dfawxynh8s5f"))))
+ "09rv0srpj8ann2n1zpv1frlpxz0x10d2y21c5lys7pmfngljlxi9"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -863,19 +864,21 @@ generated list of fallback fonts are checked.")
(assoc-ref %outputs "out")
"/lib/font-manager"))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("vala" ,vala)
- ("yelp-tools" ,yelp-tools)
+ `(("desktop-file-utils" ,desktop-file-utils)
("gettext" ,gettext-minimal)
("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("desktop-file-utils" ,desktop-file-utils)))
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala-0.50)
+ ("yelp-tools" ,yelp-tools)))
(inputs
- `(("json-glib" ,json-glib)
- ("sqlite" ,sqlite)
- ("fonconfig" ,fontconfig)
+ `(("fonconfig" ,fontconfig)
("freetype" ,freetype)
- ("gtk+" ,gtk+)))
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)
+ ("libsoup" ,libsoup)
+ ("sqlite" ,sqlite)
+ ("webkitgtk" ,webkitgtk)))
(home-page "https://fontmanager.github.io/")
(synopsis "Simple font management for GTK+ desktop environments")
(description "Font Manager is intended to provide a way for users to
@@ -962,7 +965,7 @@ Unicode Charts. It was developed for use with DejaVu Fonts project.")
(arguments
`(#:configure-flags (list "--disable-static")))
(native-inputs
- `(("gtk-doc" ,gtk-doc)
+ `(("gtk-doc" ,gtk-doc/stable)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs