aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index f83674fd58..1f65b4cdb2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1428,6 +1428,27 @@ queues header library based on circular buffer with @code{std::atomic}.")
conversions to and from strings, iteration and related functionality.")
(license license:expat)))
+(define-public mcpp
+ (package
+ (name "mcpp")
+ (version "2.7.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/mcpp/mcpp/"
+ "V." version "/mcpp-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0r48rfghjm90pkdyr4khxg783g9v98rdx2n69xn8f6c5i0hl96rv"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags #~(list "--enable-mcpplib" "--disable-static")))
+ (home-page "https://mcpp.sourceforge.net/")
+ (synopsis "C/C++ preprocessor")
+ (description
+ "@code{mcpp} is Matsui's CPP implementation precisely conformed to
+standards.")
+ (license license:bsd-2)))
+
(define-public cli11
(package
(name "cli11")
@@ -1818,7 +1839,7 @@ syntax with variables, conditions, functions and more.")
(define-public simdjson
(package
(name "simdjson")
- (version "1.0.2")
+ (version "3.1.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1827,7 +1848,7 @@ syntax with variables, conditions, functions and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "05i5jnqd7ngps79cws16ls48gnx08ykkkib3n2hbrdhr1wwrnv7a"))))
+ "0q784bm8xbz3p782dw02cdds6m71wk3acy94vva8krc9g88142ws"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; tests require downloading dependencies