aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/code.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/code.scm')
-rw-r--r--gnu/packages/code.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index d57954c47c..9cdda2b751 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2015, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2018, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2019-2023 Efraim Flashner <efraim@flashner.co.il>
@@ -562,16 +562,19 @@ stack traces.")
(assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-pwd
- ;; Lift the requirement of having a shell in PATH.
- (lambda _
+ (add-after 'unpack 'patch-references-to-commands
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Lift the requirement of having a shell and 'find' in PATH.
(substitute* "bin/geninfo"
(("qw/abs_path/")
"qw/abs_path getcwd/"))
(substitute* '("bin/lcov" "bin/geninfo")
(("`pwd`")
- "getcwd()"))
- #t))
+ "getcwd()")
+ (("`find ")
+ (string-append "`"
+ (search-input-file inputs "/bin/find")
+ " ")))))
(delete 'configure) ;no configure script
(add-after 'install 'wrap
(lambda* (#:key outputs #:allow-other-keys)