aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f38c0c07ef..2a7443314a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6170,6 +6170,46 @@ Roche 454, Ion Torrent and Pacific BioSciences SMRT.")
;; 2. MD5 implementation - RSA Data Security, RFC 1321
(license (list license:gpl2+ license:public-domain)))))
+(define-public mosaicatcher
+ (package
+ (name "mosaicatcher")
+ (version "0.3.1")
+ (source (origin
+ ;; There are no release tarballs nor tags.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/friendsofstrandseq/mosaicatcher")
+ (commit (string-append version "-dev"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n2s5wvvj2y0vfgjkg1q11xahpbagxz7h2vf5q7qyy25s12kbzbd"))
+ (patches (search-patches "mosaicatcher-unbundle-htslib.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #false ; there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "src")))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((target (assoc-ref outputs "out"))
+ (bin (string-append target "/bin"))
+ (share (string-append target "/share/mosaicatcher")))
+ (install-file "mosaic" bin)
+ (mkdir-p share)
+ (copy-recursively "../R" share)))))))
+ (inputs
+ `(("boost" ,boost)
+ ("htslib" ,htslib)))
+ (home-page "https://github.com/friendsofstrandseq/mosaicatcher")
+ (synopsis "Count and classify Strand-seq reads")
+ (description
+ "Mosaicatcher counts Strand-seq reads and classifies strand states of
+each chromosome in each cell using a Hidden Markov Model.")
+ (license license:expat)))
+
(define-public ngs-sdk
(package
(name "ngs-sdk")
il and license info. * gnu/packages/python-xyz.scm: Correct email and license info. * gnu/packages/python.scm: Correct email and license info. * gnu/packages/video.scm: Correct email and license info. * gnu/packages/web.scm: Correct email and license info. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Brendan Tildesley 2019-05-03gnu: python: Disable failing test....Fixes issue #35556 (see: https://bugs.gnu.org/35556). * gnu/packages/python.scm (python-3.7)[make-flags]: Exclude the test "test_asyncio", which currently fails. Maxim Cournoyer 2019-05-02gnu: python: Update to 3.7.3....* gnu/packages/python.scm (python-3.7): Update to 3.7.3. Marius Bakke 2019-04-18gnu: python: Disable failing tests for Python 2....Fixes issue #35311 (see: https://bugs.gnu.org/35311). * gnu/packages/python.scm (python-2.7)[make-flags]: Exclude the tests test_urllib2_localnet and test_httplib. * gnu/packages/python.scm (python-3.7)[make-flags]: Do not consider tests exclusions inherited from the python2 package, which leaves Python 3 unchanged. Maxim Cournoyer 2019-03-23gnu: Python: Remove bundled libraries....Fixes <https://bugs.gnu.org/32957>. * gnu/packages/python.scm (python-2.7)[source](snippet): Remove bundled libffi, expat and zlib. Add substitution to make pyexpat use system expat. [arguments]: Add "--with-system-expat" to #:configure-flags. [inputs]: Add EXPAT. * gnu/packages/python.scm (python-3.7)[source](snippet): Delete bundled expat and add the same pyexpat substitution. * gnu/packages/python.scm (python2-minimal, python-minimal)[inputs]: Add EXPAT. Marius Bakke 2019-03-23Merge branch 'staging' into core-updatesMarius Bakke 2019-03-18Correct name and email address for ng0....* .mailmap, Makefile.am, doc/guix.de.texi, doc/guix.fr.texi, doc/guix.texi, etc/completion/fish/guix.fish, gnu/packages/accessibility.scm, gnu/packages/admin.scm, gnu/packages/audio.scm, gnu/packages/autotools.scm, gnu/packages/cdrom.scm, gnu/packages/check.scm, gnu/packages/cinnamon.scm, gnu/packages/compression.scm, gnu/packages/crypto.scm, gnu/packages/databases.scm, gnu/packages/django.scm, gnu/packages/dns.scm, gnu/packages/elixir.scm, gnu/packages/emacs-xyz.scm, gnu/packages/emacs.scm, gnu/packages/enlightenment.scm, gnu/packages/erlang.scm, gnu/packages/fonts.scm, gnu/packages/fontutils.scm, gnu/packages/forth.scm, gnu/packages/fvwm.scm, gnu/packages/games.scm, gnu/packages/gl.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnuzilla.scm, gnu/packages/gtk.scm, gnu/packages/guile-wm.scm,gnu/packages/guile-xyz.scm, gnu/packages/haskell-check.scm, gnu/packages/haskell-crypto.scm, gnu/packages/haskell.scm, gnu/packages/image-viewers.scm, gnu/packages/image.scm, gnu/packages/irc.scm, gnu/packages/language.scm, gnu/packages/libcanberra.scm, gnu/packages/linux.scm, gnu/packages/lisp.scm, gnu/packages/lolcode.scm, gnu/packages/lxde.scm, gnu/packages/lxqt.scm, gnu/packages/mail.scm, gnu/packages/markup.scm, gnu/packages/mate.scm, gnu/packages/maths.scm, gnu/packages/mc.scm, gnu/packages/messaging.scm, gnu/packages/music.scm, gnu/packages/ncurses.scm, gnu/packages/networking.scm, gnu/packages/nickle.scm, gnu/packages/openbox.scm, gnu/packages/pdf.scm, gnu/packages/perl-check.scm, gnu/packages/perl.scm, gnu/packages/python-compression.scm, gnu/packages/python-crypto.scm, gnu/packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/ssh.scm, gnu/packages/suckless.scm, gnu/packages/tbb.scm, gnu/packages/telephony.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tls.scm, gnu/packages/tor.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/web.scm, gnu/packages/wm.scm, gnu/packages/xdisorg.scm, gnu/packages/xfce.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, gnu/services/certbot.scm, gnu/services/desktop.scm, gnu/services/version-control.scm, gnu/services/web.scm, guix/import/hackage.scm, guix/licenses.scm: Correct name and email address for ng0. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> ng0 2019-03-04gnu: Python@2: Update to 2.7.16....* gnu/packages/patches/python2-CVE-2018-1000802.patch, gnu/packages/patches/python2-CVE-2018-14647.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python.scm (python-2.7): Update to 2.7.16. [source](patches): Remove obsolete. Marius Bakke 2019-02-23gnu: Python: Consolidate test patches....While at it, adjust patches for -p1 patch flag. * gnu/packages/patches/python-fix-tests.patch: Delete file. Move contents ... * gnu/packages/patches/python-3-fix-tests.patch: ... here. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python.scm (python-3.7)[source](patches): Remove obsolete. [source](patch-flags): Remove. * gnu/packages/patches/python-3-deterministic-build-info.patch, gnu/packages/patches/python-3-search-paths.patch: Adjust for `patch -p1`. Marius Bakke 2019-02-20Merge branch 'staging' into core-updatesMarius Bakke 2019-02-20gnu: Add micropython....* gnu/packages/python.scm (micropython): New variable. Efraim Flashner 2019-02-08gnu: python-2.7: Rebuild bytecode....Fixes <https://bugs.gnu.org/22010>. * gnu/packages/python.scm (python-2.7)[arguments]: Add phase "rebuild-bytecode". (python-3.7)[arguments]: Replace "rebuild-bytecode" phase; remove outdated comment. Ricardo Wurmus 2019-02-07gnu: python: Update to 3.7.2....* gnu/packages/python.scm (python-3.7): Update to 3.7.2. Marius Bakke 2019-02-07gnu: python2: Incorporate grafted changes....* gnu/packages/python.scm (python-2.7)[source](patches): Add python2-CVE-2018-14647.patch and python2-CVE-2018-1000802.patch. [replacement]: Remove field. (python-2/fixed): Remove variable. Marius Bakke 2019-02-06Merge branch 'master' into core-updatesRicardo Wurmus 2019-01-22gnu: python2: Fix test flags....Reverts a9883939977f5fb0bd62d1dccb1ab0a772a4b720 in favor of a cleaner approach. * gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' -> 'TESTOPTS'. This overrides the default '-l' argument for memory leak checks which is not compatible with the -j for parallelism. Eric Bavier 2019-01-21gnu: python-futures: Enable tests....Re-enable the tests, as the python-2 package now has the support directory. Also, switch to running the tests via the test_futures.py script to avoid errors like: AttributeError: 'AsCompletedTests' object has no attribute 'executor' * gnu/packages/python.scm (python2-futures)[arguments]: Run the test_futures.py script to run the tests. Christopher Baines 2019-01-21gnu: python-2.7: Include /lib/python.../test/support....Don't remove the support directory from the /lib/python.../test/ directory, as this is used from the test_support module. /gnu/store/...-python2-2.7.15/lib/python2.7/test/test_support.py:2: in <module> import test.support E ImportError: No module named support * gnu/packages/python.scm (python-2.7)[arguments]: Change the 'remove-tests phase to not remove the support directory. Christopher Baines