aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8188b50ad6..a857c1ccc5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9168,37 +9168,6 @@ their variance is independent of the mean, and they are usually more sensitive
and specific in detecting differential transcription.")
(license license:artistic2.0)))
-(define-public r-gage
- (package
- (name "r-gage")
- (version "2.40.2")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "gage" version))
- (sha256
- (base32
- "1bs0hx8sqiyl08dqn2zx31kbv5aci4xvrs71pplx2yxal3jf5178"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)
- ("r-go-db" ,r-go-db)
- ("r-graph" ,r-graph)
- ("r-keggrest" ,r-keggrest)))
- (home-page (string-append "https://bmcbioinformatics.biomedcentral.com/"
- "articles/10.1186/1471-2105-10-161"))
- (synopsis "Generally applicable gene-set enrichment for pathway analysis")
- (description
- "GAGE is a published method for gene set (enrichment or GSEA) or pathway
-analysis. GAGE is generally applicable independent of microarray or RNA-Seq
-data attributes including sample sizes, experimental designs, assay platforms,
-and other types of heterogeneity. The gage package provides functions for
-basic GAGE analysis, result processing and presentation. In addition, it
-provides demo microarray data and commonly used gene set data based on KEGG
-pathways and GO terms. These functions and data are also useful for gene set
-analysis using other methods.")
- (license license:gpl2+)))
-
(define-public r-genomicfiles
(package
(name "r-genomicfiles")
>Christopher Baines 2023-02-16gnu: Remove unneeded module imports....* gnu/packages/abiword.scm, * gnu/packages/ada.scm, * gnu/packages/agda.scm, * gnu/packages/backup.scm, * gnu/packages/barrier.scm, * gnu/packages/bioinformatics.scm, * gnu/packages/bootstrap.scm, * gnu/packages/bqn.scm, * gnu/packages/c.scm, * gnu/packages/chemistry.scm, * gnu/packages/coq.scm, * gnu/packages/cross-base.scm, * gnu/packages/databases.scm, * gnu/packages/emacs-xyz.scm, * gnu/packages/enlightenment.scm, * gnu/packages/games.scm, * gnu/packages/geo.scm, * gnu/packages/ghostscript.scm, * gnu/packages/gl.scm, * gnu/packages/golang.scm, * gnu/packages/jami.scm, * gnu/packages/java-maths.scm, * gnu/packages/kde-frameworks.scm, * gnu/packages/kde-plasma.scm, * gnu/packages/language.scm, * gnu/packages/libreoffice.scm, * gnu/packages/linphone.scm, * gnu/packages/lisp.scm, * gnu/packages/llvm.scm, * gnu/packages/machine-learning.scm, * gnu/packages/minetest.scm, * gnu/packages/monitoring.scm, * gnu/packages/nfs.scm, * gnu/packages/ocr.scm, * gnu/packages/opencl.scm, * gnu/packages/pdf.scm, * gnu/packages/python-xyz.scm, * gnu/packages/racket.scm, * gnu/packages/rust.scm, * gnu/packages/syncthing.scm, * gnu/packages/syndication.scm, * gnu/packages/telegram.scm, * gnu/packages/vulkan.scm, * gnu/packages/web-browsers.scm, * gnu/packages/web.scm, * gnu/packages/webkit.scm: Remove some unecessary module imports. Efraim Flashner 2023-02-13gnu: LLVM, Clang, libomp, lld: Update to 15.0.7....* gnu/packages/llvm.scm (llvm-15, clang-15, libomp-15, lld-15): Update to 15.0.7. Signed-off-by: Christopher Baines <mail@cbaines.net> Greg Hogan 2023-01-30gnu: Add llvm-for-mesa....* gnu/packages/llvm.scm (llvm-for-mesa): New variable. Efraim Flashner 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2023-01-09gnu: LLVM, Clang, libomp, lld: Update to 15.0.6....* gnu/packages/llvm.scm (llvm-15, clang-15, libomp-15, lld-15): Update to 15.0.6. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Greg Hogan 2023-01-02gnu: Add lld-11....* gnu/packages/llvm.scm (lld-11): New variable. Efraim Flashner 2022-12-08gnu: julia: Update to 1.8.3....* gnu/packages/julia.scm (julia): Update to 1.8.3. [source]: Remove one patch. [arguments]: Adjust 'prepare-deps phase to changes in inputs. Remove custom 'use-system-libwhich, 'change-number-of-precompiled-statements, 'symlink-libraries phases. In 'fix-include-and-link-paths phase remove substitution for utf8proc linking and adjust libuv linking. Fix reference to shell in 'replace-default-shell phase. Adjust the 'shared-objects-path phase to changes in the source. Change the 'enable-parallel-tests phase for upstream changes. Adjust the 'adjust-test-suite phase to be more robust. Change the 'disable-broken-tests phase to help the test suite pass. Rename 'symlink-llvm-utf8proc phase to 'symlink-missing-libraries and add two more. Adjust make-flags for changes in shared system libraries. Reorder make-flags to changes in the source. Except for aarch64, use the defaults for choosing to use 64-bit blas. [inputs]: Add libblastrampoline. Replace libgit-1.1 with libgit-1.3, utf8proc-2.7.1 with utf8proc-2.8.0. [native-inputs]: Replace python-2 with python. (libunwind-julia): Update to 1.5.0. [source]: Update patches. * gnu/packages/libevent.scm (libuv-julia): Update to 2.0.0-4.e6f0e49. [arguments]: Also build static library, build position-independent-code. * gnu/packages/llvm.scm (llvm-julia): Update to llvm-13, following upstream's build instructions. * gnu/packages/maths.scm (openlibm): Update to 0.8.1. * gnu/packages/textutils.scm (utf8proc-2.7.1): Update and rename to utf8proc-2.8.0. [native-inputs]: Update unicode to 14.0.0. * gnu/packages/tls.scm (mbedtls-apache): Update to 2.28.0. [source]: Remove snippet. [arguments]: Remove trailing #t from phases. * gnu/packages/patches/julia-allow-parallel-build.patch, (julia-patch): Update version string to 1.8.2. gnu/packages/patches/libunwind-julia-fix-GCC10-fno-common.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them. Co-authored-by: Akira Kyle <akira@akirakyle.com> Efraim Flashner 2022-11-22gnu: libcxx: Update to 15.0.5....* gnu/packages/llvm.scm (libcxx): Update to 15.0.5. [version]: Use version from LLVM-15. Signed-off-by: Christopher Baines <mail@cbaines.net> Greg Hogan 2022-11-22gnu: lldb: Update to 15.0.5....* gnu/packages/llvm.scm (lldb): Update to 15.0.5. [version]: Use version from LLVM-15. [inputs]: Change from LLVM-14 and CLANG-14 to LLVM-15 and CLANG-15. Signed-off-by: Christopher Baines <mail@cbaines.net> Greg Hogan 2022-11-22gnu: LLVM, Clang, libomp, lld: Update to 15.0.5....* gnu/packages/llvm.scm (llvm-15, clang-15, libomp-15, lld-15): Update to 15.0.5. (lld)[version]: Use version from LLVM-15. (%llvm-monorepo-hashes, %llvm-patches): Adjust accordingly. Signed-off-by: Christopher Baines <mail@cbaines.net> Greg Hogan 2022-11-19gnu: make-lld-wrapper: Inherit version, license and home-page from LLD....* gnu/packages/llvm.scm (make-lld-wrapper): Inherit from the provided LLD. Marius Bakke 2022-11-17gnu: lld-as-ld-wrapper: Add version 15....* gnu/packages/llvm.scm (lld-as-ld-wrapper-15): New variable. Marius Bakke 2022-11-17gnu: Add lld-15....* gnu/packages/llvm.scm (lld-15): New variable. (lld-14): Inherit from lld-15. Efraim Flashner 2022-11-16gnu: Add clang-toolchain-15....* gnu/packages/llvm.scm (clang-toolchain-15): New variable. Maxim Cournoyer 2022-11-16gnu: Add libomp-15....* gnu/packages/llvm.scm (libomp-15): New variable. (libomp-14): Inherit from it. [arguments]: Use substitute-keyword-arguments and override the chdir-to-source-and-install-license phase. Remove redundant fields. Maxim Cournoyer 2022-11-16gnu: Add clang-15....* gnu/packages/llvm.scm (clang-from-llvm): Add LEGACY-BUILD-SHARED-LIBS? argument and update doc. [configure-flags]: Conditionally add -DCLANG_LINK_CLANG_DYLIB=ON. [phases]{change-directory}: Conditionally add phase. {add-tools-extra}: Conditionally patch AddClang.cmake file. (clang-15): New variable. (clang-14): Streamline. (clang-13, clang-12, clang-11, clang-10, clang-9, clang-8, clang-7, clang-6) (clang-3.9.1, clang-3.8, clang-3.7, clang-3.5): Set LEGACY-BUILD-SHARED-LIBS? argument to #t. Maxim Cournoyer 2022-11-16gnu: Add clang-runtime-15....* gnu/packages/llvm.scm (clang-runtime-15): New variable. Maxim Cournoyer 2022-11-16gnu: Add llvm-15....* gnu/packages/llvm.scm (llvm-15): New variable. (llvm-14): Inherit from it, removing duplicated fields. * gnu/packages/patches/clang-15.0-libc-search-path.patch: New file. * gnu/local.mk: Register it. Maxim Cournoyer 2022-11-06gnu: libcxx+libcxxabi: Use G-expressions....* gnu/packages/llvm.scm (libcxx+libcxxabi-6)[arguments]: Use G-expressions. <#:configure-flags>: Use "this-package-native-input". Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zhu Zihao 2022-11-06gnu: libcxxabi: Use G-expressions....* gnu/packages/llvm.scm (libcxxabi-6)[arguments]: Use G-expressions. <#:configure-flags>: Use "this-package-native-input". Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zhu Zihao 2022-11-06gnu: libcxx: Update to 14.0.6....* gnu/packages/llvm.scm(libcxx)[source]: Use "llvm-monorepo". [arguments]<#:configure-flags>: Use clang & clang++, skip RPATH_CHANGE in CMake. <#:phases>: Add phase "enter-subdirectory". [native-inputs]: Add Python 3 for lit. (libcxx-6)[arguments]: Don't inherit from libcxx. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zhu Zihao 2022-11-06gnu: libcxx: Use G-expressions....* gnu/packages/llvm.scm (libcxx)[arguments]: Use G-expressions. (libcxx-6)[arguments]: Use G-expressions. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Zhu Zihao 2022-09-08gnu: clang-runtime: Remove obsolete workaround....* gnu/packages/llvm.scm (clang-runtime-14)[native-inputs]: Remove. Marius Bakke 2022-09-08Merge branch 'staging' into core-updatesMarius Bakke 2022-09-03gnu: cling: Use gexps....* gnu/packages/llvm.scm (cling)[configure-flags]: Use gexps and search-input-file. [phases]: Likewise. {patch-paths}: Use search-input-file and this-package-input. {delete-static-libraries}: Adjust for gexps. Maxim Cournoyer 2022-09-01gnu: llvm-14, llvm-12: Enable RTTI....* gnu/packages/llvm.scm (llvm-14, llvm-12): Enable RTTI. [arguments]<#:configure-flags>: Switch to proper CMake flag. Signed-off-by: Marius Bakke <marius@gnu.org> Greg Hogan 2022-08-30Merge branch 'staging' into core-updatesMarius Bakke 2022-08-29gnu: emacs-clang-format: Remove inherited propagated inputs....* gnu/packages/llvm.scm (emacs-clang-format)[propagated-inputs]: Remove them. Clément Lassieur 2022-08-27gnu: llvm-11: Update to 11.1.0....* gnu/packages/llvm.scm (llvm-11, clang-runtime-11, clang-11, libomp-11): Update to 11.1.0. Signed-off-by: Marius Bakke <marius@gnu.org> Greg Hogan 2022-08-11Merge branch 'staging' into core-updatesMarius Bakke 2022-08-11gnu: LLVM: Add missing include statement for compatibility with GCC 11....* gnu/packages/patches/llvm-8-missing-include.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (llvm-11, llvm-10, llvm-9, llvm-8)[source](patches): Add it. Marius Bakke