aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 8bcc87b1a2..1f4a437e5e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -723,7 +723,13 @@ series in Python.")
(lambda _
(substitute* "setup.cfg"
;; packaging>=23.1
- ((">=23.1") ">=21.3")))))))
+ ((">=23.1") ">=21.3"))))
+ (add-before 'check 'set-home
+ (lambda _
+ ;; Relax matplotlib warning: ... because the default path
+ ;; (/homeless-shelter/.config/matplotlib) is not a writable
+ ;; directory ...
+ (setenv "HOME" "/tmp"))))))
(propagated-inputs
(list opencv
python-astropy