aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 193a4d25c9..c4ecc6d08e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5925,7 +5925,7 @@ Grace Roman Space Telescope.")
(define-public python-radio-beam
(package
(name "python-radio-beam")
- (version "0.3.7")
+ (version "0.3.8")
(source
(origin
(method url-fetch)
@@ -5933,13 +5933,24 @@ Grace Roman Space Telescope.")
(sha256
(base32 "0dg6vqdhmzh47awdkkcbf455gw6if2qwxyhcqbq2dkhbwsx680gc"))))
(build-system pyproject-build-system)
+ (arguments
+ ;; See <https://github.com/radio-astro-tools/radio-beam/issues/129>.
+ ;; E astropy.units.core.UnitScaleError: cannot create a unit with a scale of 0.
+ ;;
+ ;; It might happen due to older version of NumPy in Guix, upastream
+ ;; tested with numpy==2.1.2, where we have 1.23.2.
+ (list #:tests? #f))
+ (native-inputs
+ (list python-pytest-astropy
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-astropy
python-matplotlib
python-numpy
python-scipy
python-six))
- (native-inputs (list python-pytest-astropy python-setuptools-scm))
(home-page "https://radio-beam.readthedocs.io/en/latest/")
(synopsis "Operations for radio astronomy beams with Astropy")
(description