We want to allow builds in chroots that lack /bin/sh. Thus, system(3) and popen(3) need to be tweaked to use the right shell. For the bootstrap glibc, we just use whatever `sh' can be found in $PATH. The final glibc instead uses the hard-coded absolute file name of `bash'. --- a/sysdeps/posix/system.c +++ b/sysdeps/posix/system.c @@ -134,7 +134,7 @@ do_system (const char *line) INIT_LOCK (); /* Exec the shell. */ - (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ); + (void) __execvpe (SHELL_NAME, (char *const *) new_argv, __environ); _exit (127); } else if (pid < (pid_t) 0) --- a/libio/iopopen.c +++ b/libio/iopopen.c @@ -145,7 +145,7 @@ _IO_new_proc_open (fp, command, mode) _IO_close (fd); } - _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0); + execlp ("sh", "sh", "-c", command, (char *) 0); _IO__exit (127); } _IO_close (child_end); s Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index dd9e6d0dc4..1891cec452 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -64,7 +64,7 @@
(add-after 'install 'install-info
(lambda _
(invoke "make" "install_doc"))))))
- (home-page "http://www.nasm.us/")
+ (home-page "https://www.nasm.us/")
(synopsis "80x86 and x86-64 assembler")
(description
"NASM, the Netwide Assembler, is an 80x86 and x86-64 assembler designed