aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm78
1 files changed, 34 insertions, 44 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index e0d2147eb3..deb2b8706e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -327,12 +327,9 @@ interface and is based on GNU Guile.")
(license license:gpl3+)
(home-page "https://www.gnu.org/software/shepherd/")))
-;; Update on the next rebuild cycle.
-(define-public shepherd shepherd-0.8)
-
(define-public shepherd-0.9
(package
- (inherit shepherd)
+ (inherit shepherd-0.8)
(version "0.9.3")
(source (origin
(method url-fetch)
@@ -367,6 +364,8 @@ interface and is based on GNU Guile.")
guile-fibers-1.1)) ;for cross-compilation
(inputs (list guile-3.0-latest guile-fibers-1.1))))
+(define-public shepherd shepherd-0.9)
+
(define-public guile2.2-shepherd
(package
(inherit shepherd-0.9)
@@ -896,14 +895,14 @@ re-executing them as necessary.")
(define-public inetutils
(package
(name "inetutils")
- (version "2.0")
+ (version "2.3")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/inetutils/inetutils-"
- version ".tar.gz"))
- (sha256
- (base32
- "0j1nb69bhg29cm4xkqqjh2ln1zqcj2lnpm92v638lpwrs11dypxl"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/inetutils/inetutils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1dj4ilxy1wrfxhxc85iya3x28h1mhjpqc5nv862xcq3ww2gqkv8w"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--localstatedir=/var"
@@ -927,19 +926,21 @@ re-executing them as necessary.")
;; Make sure that canonical "coreutils" package is not referred.
#:make-flags
(list (string-append "CPPFLAGS=-DPATHDEF_CP=\\\""
- (assoc-ref %build-inputs "coreutils*")
- "/bin/cp\\\""))
+ (search-input-file %build-inputs "bin/cp")
+ "\\\""))
;; On some systems, 'libls.sh' may fail with an error such as:
;; "Failed to tell switch -a apart from -A".
#:parallel-tests? #f))
- (inputs `(("coreutils*" ,coreutils)
- ("shadow" ,shadow) ;for login (used in telnetd and rlogind)
- ("ncurses" ,ncurses)
- ("readline" ,readline))) ;for 'ftp'
- (native-inputs (if (member (%current-system)
- (package-supported-systems net-tools))
- `(("netstat" ,net-tools)) ;for tests
- '()))
+ (inputs
+ (list coreutils
+ shadow ;for login (used in telnetd and rlogind)
+ ncurses
+ readline)) ;for 'ftp'
+ (native-inputs
+ (if (member (%current-system)
+ (package-supported-systems net-tools))
+ (list net-tools) ;for tests
+ '()))
(home-page "https://www.gnu.org/software/inetutils/")
(synopsis "Basic networking utilities")
(description
@@ -951,15 +952,15 @@ hostname.")
(define-public shadow
(package
(name "shadow")
- (version "4.9")
+ (version "4.13")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/shadow-maint/shadow/releases/"
- "download/v" version "/shadow-" version ".tar.xz"))
+ "download/" version "/shadow-" version ".tar.xz"))
(sha256
(base32
- "0i4iijbshnwnsrskxzrh18xgmzff0hdpsnnkmyc2gdn1x4n1zv7y"))))
+ "0b6xz415b4y3y5nk3pw9xibv05kln4cjbmhybyncmrx2g5fj9zls"))))
(build-system gnu-build-system)
(arguments
`(;; Assume System V `setpgrp (void)', which is the default on GNU
@@ -1001,7 +1002,13 @@ hostname.")
(substitute* "lib/nscd.c"
(("/usr/sbin/nscd")
(string-append libc "/sbin/nscd"))))))
- (add-after 'install 'remove-groups
+ (add-after 'install 'install-man-pages
+ (lambda _
+ ;; The top-level Makefile.am wrongfully has "SUBDIRS += man"
+ ;; under "if ENABLE_REGENERATE_MAN", even though prebuilt man
+ ;; pages are available. Thus, install them manually.
+ (invoke "make" "-C" "man" "install")))
+ (add-after 'install-man-pages 'remove-groups
(lambda* (#:key outputs #:allow-other-keys)
;; Remove `groups', which is already provided by Coreutils.
(let* ((out (assoc-ref outputs "out"))
@@ -1022,27 +1029,10 @@ hostname.")
"Shadow provides a number of authentication-related tools, including:
login, passwd, su, groupadd, and useradd.")
- (properties '((hidden? . #t))) ;see below
-
;; The `vipw' program is GPLv2+.
;; libmisc/salt.c is public domain.
(license license:bsd-3)))
-(define-public shadow-with-man-pages
- ;; TODO: Merge with 'shadow' on the next core-updates cycle.
- (package/inherit shadow
- (properties '()) ;not hidden
- (arguments
- (substitute-keyword-arguments (package-arguments shadow)
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (add-after 'install 'install-man-pages
- (lambda _
- ;; The top-level Makefile.am wrongfully has "SUBDIRS += man"
- ;; under "if ENABLE_REGENERATE_MAN", even though prebuilt man
- ;; pages are available. Thus, install them manually.
- (invoke "make" "-C" "man" "install")))))))))
-
(define-public mingetty
(package
(name "mingetty")
@@ -1535,7 +1525,7 @@ connection alive.")
(list config perl file))
(inputs `(("inetutils" ,inetutils)
- ("bash" ,(canonical-package bash-minimal)) ;for wrap-program
+ ("bash" ,bash-minimal)
,@(if (hurd-target?) '()
`(("net-tools" ,net-tools)
("iproute" ,iproute)))
@@ -2940,7 +2930,7 @@ provides the following commands:
;; variable in the tests/cpan.scm test.
(list (search-path-specification
(variable "GUIX_PYTHONPATH")
- (files (list "lib/python3.9/site-packages")))))
+ (files (list "lib/python3.10/site-packages")))))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")
(description "Ansible aims to be a radically simple IT automation system.