;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2015, 2016 Mark H Weaver ;;; Copyright © 2016, 2017, 2020, 2022 Efraim Flashner ;;; Copyright © 2017 Clément Lassieur ;;; Copyright © 2017 Ricardo Wurmus ;;; Copyright © 2019, 2020 Marius Bakke ;;; Copyright © 2019 Mathieu Othacehe ;;; Copyright © 2020 Björn Höfling ;;; Copyright © 2020 Julien Lepiller ;;; Copyright © 2021 Guillaume Le Vaillant ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages icu4c) #:use-module (gnu packages) #:use-module (gnu packages java) #:use-module (gnu packages perl) #:use-module (gnu packages python) #:use-module (guix gexp) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix utils) #:use-module (guix download) #:use-module (guix build-system ant) #:use-module (guix build-system gnu)) (define-public icu4c (package (name "icu4c") (version "69.1") (source (origin (method url-fetch) (uri (string-append "https://github.com/unicode-org/icu/releases/download/release-" (string-map (lambda (x) (if (char=? x #\.) #\- x)) version) "/icu4c-" (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version) "-src.tgz")) (sha256 (base32 "0icps0avkwy5df3wwc5kybxcg63hcgk4phdh9g244g0xrmx7pfjc")))) (build-system gnu-build-system) ;; When cross-compiling, this package needs a source directory of a ;; native-build of itself. (native-inputs `(("python" ,python-minimal) ,@(if (%current-target-system) `(("icu4c-build-root" ,icu4c-build-root)) '()))) (inputs (list perl)) (arguments `(#:configure-flags (list "--enable-rpath" ,@(if (%current-target-system) '((string-append "--with-cross-build=" (assoc-ref %build-inputs "icu4c-build-root"))) '())) #:phases (modify-phases %standard-phases (add-after 'unpack 'chdir-to-source (lambda _ (chdir "source") #t)) (add-after 'chdir-to-source 'update-LDFLAGS (lambda _ ;; Do not create a "data-only" libicudata.so because it causes ;; problems on some architectures (notably armhf and MIPS). (substitute* "config/mh-linux" (("LDFLAGSICUDT=-nodefaultlibs -nostdlib") "LDFLAGSICUDT=")) #t)) ,@(if (target-riscv64?) `((add-after 'unpack 'disable-failing-test ;; It is unknown why this test is failing. (lambda _ (substitute* "source/test/intltest/numbertest_api.cpp" (("(TESTCASE_AUTO\\(unitUsage\\));" all) (string-append "//" all)))))) '()) (add-after 'install 'avoid-coreutils-reference ;; Don't keep a reference to the build tools. (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (substitute* (find-files (string-append out "/lib/icu") "\\.inc$") (("INSTALL_CMD=.*/bin/install") "INSTALL_CMD=install")) #t)))))) (synopsis "International Components for Unicode") (description "ICU is a set of C/C++ and Java libraries providing Unicode and globalisation support for software applications. This package contains the C/C++ part.") (license x11) (home-page "http://site.icu-project.org/"))) (define-public icu4c-71 (package (inherit icu4c) -rw-r--r--gnu/packages/admin.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c331a662a7..0bc1d160fb 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1456,6 +1457,53 @@ commands and their arguments.")
;; See <http://www.sudo.ws/sudo/license.html>.
(license license:x11)))
+(define-public opendoas
+ (package
+ (name "opendoas")
+ (version "6.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Duncaen/OpenDoas.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07kkc5729p654jrgfsc8zyhiwicgmq38yacmwfvay2b3gmy728zn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; The configure script doesn't accept most of the default flags.
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ ;; The configure script can only be told which compiler to use
+ ;; through environment variables.
+ (setenv "CC" ,(cc-for-target))
+ (apply invoke "./configure" configure-flags)))
+ (add-before 'install 'fix-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "bsd.prog.mk"
+ (("^\tchown.*$") ""))
+ #t)))
+ #:configure-flags
+ (list (string-append "--prefix=" (assoc-ref %outputs "out"))
+ (string-append "--target=" (or ,(%current-target-system) ""))
+ "--with-timestamp")
+ ;; Compiler choice is not carried over from the configure script.
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target)))
+ #:tests? #f)) ; no test suite
+ (native-inputs
+ `(("bison" ,bison)))
+ (home-page "https://github.com/Duncaen/OpenDoas")
+ (synopsis "Portable version of OpenBSD's doas command")
+ (description "Doas is a minimal replacement for the venerable sudo. It was
+initially written by Ted Unangst of the OpenBSD project to provide 95% of the
+features of sudo with a fraction of the codebase.")
+ (license (list license:bsd-3 ; libbsd/*
+ license:isc)))) ; everything else
+
(define-public wpa-supplicant-minimal
(package
(name "wpa-supplicant-minimal")