aboutsummaryrefslogtreecommitdiff
path: root/gnu/local.mk
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/local.mk')
-rw-r--r--gnu/local.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a06f359435..739d92a7b0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -321,6 +321,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/rsync.scm \
%D%/packages/ruby.scm \
%D%/packages/rush.scm \
+ %D%/packages/rust.scm \
%D%/packages/samba.scm \
%D%/packages/sawfish.scm \
%D%/packages/scanner.scm \
module (guix licenses) #:use-module (guix packages) #:use-module (gnu packages python) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public re2c (package (name "re2c") (version "2.2") (source (origin (method url-fetch) (uri (string-append "https://github.com/skvadrik/" name "/releases/download/" version "/" name "-" version ".tar.xz")) (sha256 (base32 "1nkbv3bxz1kwwql1pdlnj3lxy5h2vsaif393ivb5b9d8610mxi0g")))) (build-system gnu-build-system) (home-page "https://re2c.org/") (native-inputs (list python)) ; for the test driver (synopsis "Lexer generator for C/C++") (description "@code{re2c} generates minimalistic hard-coded state machine (as opposed to full-featured table-based lexers). Flexible API allows generated code to be wired into virtually any environment. Instead of exposing traditional @code{yylex()} style API, re2c exposes its internals. Be sure to take a look at examples, they cover a lot of real-world cases and shed some light on dark corners of re2c API.") (license public-domain)))