aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/backup.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 19c261ea82..c5bee744dd 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -675,14 +675,13 @@ detection, and lossless compression.")
(define-public borg
(package
(name "borg")
- (version "1.2.8")
+ (version "1.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(sha256
- (base32 "1aplj54x6hcyg3mnzscnwi07npy7nrws2246ss25ax6bsaq257fk"))
- (modules '((guix build utils)))
+ (base32 "0agdyrmj7yy2vn0qghcpq458v9d09q9jvzzrszz6dyj3aqalak65"))
(snippet
#~(begin
;; Delete files generated by Cython. We used to have a regex that
@@ -701,11 +700,7 @@ detection, and lossless compression.")
"src/borg/platform/linux.c"
"src/borg/platform/posix.c"
"src/borg/platform/syncfilerange.c"
- "src/borg/platform/windows.c"))
- ;; Remove bundled shared libraries.
- (with-directory-excursion "src/borg/algorithms"
- (for-each delete-file-recursively
- (list "lz4" "xxh64" "zstd")))))))
+ "src/borg/platform/windows.c"))))))
(build-system python-build-system)
(arguments
(list
@@ -716,10 +711,12 @@ detection, and lossless compression.")
#~(modify-phases %standard-phases
(add-after 'unpack 'set-env
(lambda* (#:key inputs #:allow-other-keys)
- (let ((openssl #$(this-package-input "openssl"))
+ (let ((acl #$(this-package-input "acl"))
+ (openssl #$(this-package-input "openssl"))
(lz4 #$(this-package-input "lz4"))
(xxhash #$(this-package-input "xxhash"))
(zstd #$(this-package-input "zstd")))
+ (setenv "BORG_LIBACL_PREFIX" acl)
(setenv "BORG_OPENSSL_PREFIX" openssl)
(setenv "BORG_LIBLZ4_PREFIX" lz4)
(setenv "BORG_LIBXXHASH_PREFIX" xxhash)
@@ -756,7 +753,8 @@ detection, and lossless compression.")
(add-after 'install 'install-doc
(lambda _
(let ((man (string-append #$output "/share/man/man1"))
- (misc (string-append #$output "/share/borg/misc")))
+ (misc (string-append #$output "/share/doc/borg-"
+ #$(package-version this-package))))
(for-each (cut install-file <> misc)
'("docs/misc/create_chunker-params.txt"
"docs/misc/borg-data-flow.png"