aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/game-development.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 6525f94304..f39c9d444b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -457,18 +457,16 @@ etc.")
(define-public aseprite
(package
(name "aseprite")
- (version "1.1.1")
- ;; The release tarball isn't good enough because it's missing some
- ;; necessary code that is only in git submodules.
+ (version "1.1.13")
+ ;; TODO: Unbundle third party software.
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aseprite/aseprite.git")
- (commit "v1.1.1")
- (recursive? #t)))
+ (method url-fetch/zipbomb)
+ (uri (string-append "https://github.com/aseprite/aseprite"
+ "/releases/download/v" version
+ "/Aseprite-v" version "-Source.zip"))
(sha256
(base32
- "1yr0l3bc68lyrffrzxgw98zznv8yz5ldl98lyvp6s5grny4s4jyk"))))
+ "0sm5vrrinpj423cpnlrczknjnykrn6q8c5qn2fmg5v22cv70dwzl"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags
r PGP key separately....Tobias Geerinckx-Rice 2019-07-08guix-install.sh: Add missing ‘local’ declaration....Tobias Geerinckx-Rice 2019-07-08guix-install.sh: Treat REQUIRE as the array it is....Tobias Geerinckx-Rice 2019-07-01etc: Do not recommend use of SKS key servers....Ricardo Wurmus 2019-06-29guix-install.sh: Don't authorise hydra.gnu.org....Tobias Geerinckx-Rice 2019-05-10etc: Refer to ci.guix.gnu.org in install script....Ricardo Wurmus 2019-05-02guix-install.sh: Update URL....Ludovic Courtès 2019-02-05guix-install.sh: Avoid "#!/bin/bash" shebang....Ludovic Courtès 2018-12-13guix-install.sh: Use pool.sks-keyservers.net....Ludovic Courtès 2018-12-05guix-install.sh: Use the "ci.guix.info.pub" file name for clarity....Ludovic Courtès 2018-11-23build: Binary tarball now populates the "current-guix" profile....Ludovic Courtès 2018-10-14guix-install.sh: Recognize armhf-linux....Ludovic Courtès 2018-05-19guix-install.sh: Fix chk_require exiting without warning....Maxim Cournoyer 2018-03-29guix-install.sh: Explicitly set root's home directory....Chris Marusich