aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pulseaudio.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index c58d479081..f4817041ff 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -287,13 +287,14 @@ sinks.")
(name "pulsemixer")
(version "1.4.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/GeorgeFilipkin/"
- "pulsemixer/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GeorgeFilipkin/pulsemixer")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1lpad90ifr2xfldyf39sbwx1v85rif2gm9w774gwwpjv53zfgk1g"))))
+ "0l5zawv36d46sj3k31k5w6imnnxzyn62r83wdhr7fp5mi3ls1h5x"))))
(build-system python-build-system)
(arguments
`(#:phases
21-05-10 10:18:19 -0400'>2021-05-10system: vm-image.tmpl: Add a crutch to allow refreshing the resolution....Inspired by https://github.com/jollheef/appvm/commit/1270b2e209bc002e69bbe6351ad5b04b7facfcc8. The price to pay is about 5% of a CPU core usage in the guest in the worst scenario. * gnu/system/examples/vm-image.tmpl (auto-update-resolution-crutch): New mcron job. [services]: Extend the mcron-service with it. Maxim Cournoyer 2021-05-06gnu: system: Add SPICE capability to the VM image....* gnu/system/examples/vm-image.tmpl (services) [spice-vdagent-service-type]: Add service. [slim-service-type] <xorg-configuration>: Add the xf86-video-qxl module. Maxim Cournoyer 2021-01-19system: Rename 'disk-image' command 'image'....* guix/scripts/system.scm (system-derivation-for-action): Rename 'disk-image' command 'image'. Warn when using the now deprecated 'disk-image' command. (show-help): Adapt accordingly. (guix-system): Ditto. * tests/guix-system.sh: Ditto. * gnu/system/examples/bare-hurd.tmpl: Ditto. * doc/guix.texi (Building the Installation Image, Building the Installation Image for ARM Boards, Invoking guix pack, Invoking guix system): Adapt documentation. Mathieu Othacehe 2020-11-05services: Add yggdrasil-service-type....* gnu/services/networking.scm (yggdrasil-configuration) (yggdrasil-configuration?, yggdrasil-configuration-package) (yggdrasil-configuration-auto-conf, yggdrasil-configuration-log-level) (yggdrasil-configuration-log-to): New procedures. (yggdrasil-service-type): New variable. * doc/guix.texi: Document it. * gnu/system/examples/yggdrasil.tmpl: Provide example. Signed-off-by: Julien Lepiller <julien@lepiller.eu> raingloom 2020-10-13installer: Add Emacs EXWM desktop environment....Suggested by zenny via IRC. * gnu/installer/services.scm (%system-services): Add emacs, emacs-exwm, emacs-desktop-environment. * etc/release-manifest.scm (%system-packages): Likewise. * gnu/system/examples/lightweight-desktop.tmpl: Likewise. * gnu/tests/install.scm (installation-target-desktop-os-for-gui-tests) [packages]: Likewise * gnu/installer/newt/services.scm (run-desktop-environments-cbt-page): Make one entry taller. Jan (janneke) Nieuwenhuizen 2020-10-09system: hurd: Add PAM support with shadow and sudo....* gnu/system.scm (hurd-default-essential-services): Add setuid-program-service-type. * gnu/system/hurd.scm (%base-packages/hurd): Add shadow, sudo. (%setuid-programs/hurd): New variable. (%hurd-default-operating-system)[setuid-program]: Use it. [pam-services, sudoers-file]: Remove overrides; enabling regular defaults. * gnu/system/examples/bare-hurd.tmpl (%hurd-os)[users]: New field. [services]: Do not disable PAM in SSH. Jan (janneke) Nieuwenhuizen 2020-08-28system: Remove extra line from 'lightweight-desktop.tmpl'....This is a followup to c7af96871737ffa0e2be879e200573bc60603c8c. * gnu/system/examples/lightweight-desktop.tmpl: Remove extra 'use-package-modules' line. Ludovic Courtès 2020-07-29examples: Add password for Alice's brother....* gnu/system/examples/desktop.tmpl (users)[bob]: Add password. Oleg Pykhalov 2020-06-13system: bare-hurd.tmpl: Add openssh-sans-x client and service....* gnu/system/examples/bare-hurd.tmpl (%hurd-os)[packages]: Add openssh-sans-x. [services]: Add openssh-service. Add example usage. Jan (janneke) Nieuwenhuizen 2020-06-08system: examples: Add bare-hurd.tmpl....* gnu/system/hurd.scm (%hurd-def%hurd-default-operating-system-kernel, %hurd-default-operating-system): New exported variables. * gnu/system/examples/bare-hurd.tmpl: New file. * Makefile.am (EXAMPLES): Add it. * tests/guix-system.sh: Add --target=i586-pc-gnu when testing it. Jan (janneke) Nieuwenhuizen 2020-06-08system: bare-bones: Remove dependency to X libraries....Use "openssh-sans-x" to prevent the inclusion of X libraries to the bare-bones system closure. * gnu/system/examples/bare-bones.tmpl (operating-system)[services]: Use openssh-sans-x instead of openssh. Mathieu Othacehe