aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ham-radio.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index 66f17c7598..0758617176 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -423,3 +423,41 @@ to the fix block above.
@end itemize")
(home-page "https://git.osmocom.org/gr-iqbal/")
(license license:gpl3+)))
+
+(define-public gqrx
+ (package
+ (name "gqrx")
+ (version "2.12.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/csete/gqrx.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00alf3q6y313xpx6p7v43vqsphd2x4am4q362lw21bcy9wc4jidw"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("fftwf" ,fftwf)
+ ("gmp" ,gmp)
+ ("gnuradio" ,gnuradio)
+ ("gnuradio-iqbalance" ,gnuradio-iqbalance)
+ ("gnuradio-osmosdr" ,gnuradio-osmosdr)
+ ("jack" ,jack-1)
+ ("log4cpp" ,log4cpp)
+ ("portaudio" ,portaudio)
+ ("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)))
+ (arguments
+ `(#:tests? #f)) ; No tests
+ (synopsis "Software defined radio receiver")
+ (description "Gqrx is a software defined radio (SDR) receiver implemented
+using GNU Radio and the Qt GUI toolkit.")
+ (home-page "https://gqrx.dk/")
+ (license license:gpl3+)))
rvices requirements....Mathieu Othacehe 2021-02-23services: cuirass: Improve simple-cuirass-services....Mathieu Othacehe 2021-02-22services: cuirass: Instantiate postgresql service....Mathieu Othacehe 2021-02-22services: cuirass: Add parameters support....Mathieu Othacehe 2021-02-19services: cuirass: Add "simple-cuirass-services"....Mathieu Othacehe 2021-02-12services: cuirass: Add server argument for the remote-worker....Mathieu Othacehe 2021-02-09services: cuirass: Move zabbix argument to the web process....Mathieu Othacehe 2021-02-08services: cuirass: Add Zabbix support....Mathieu Othacehe 2021-01-28services: cuirass: Create remote-server cache directory....Mathieu Othacehe 2021-01-28services: cuirass: Fix syntax error....Mathieu Othacehe 2021-01-28services: cuirass: Add log-file support....Mathieu Othacehe 2021-01-28services: cuirass: Fix workers argument....Mathieu Othacehe 2021-01-28services: cuirass: Add systems argument....Mathieu Othacehe 2021-01-28services: cuirass: Add remote build support.Mathieu Othacehe 2021-01-28service: cuirass: Update it.Mathieu Othacehe 2020-12-08services: cuirass: Add queue-size option....Mathieu Othacehe 2020-10-02services: cuirass: Fix activation....Mathieu Othacehe 2020-09-24services: cuirass: Create queries log files at activation....Mathieu Othacehe 2020-09-24services: cuirass: Add web SQL queries logging support....Mathieu Othacehe 2020-09-24services: cuirass: Add SQL queries logging support....Mathieu Othacehe